Download it now!
Bug 48483 - FILEOPEN: Custom shapes badly inserted from Gallery
Summary: FILEOPEN: Custom shapes badly inserted from Gallery
Status: RESOLVED DUPLICATE of bug 47406
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-09 14:33 UTC by Laurent BP
Modified: 2013-05-22 20:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of clipart badly inserted in LibO 3.5 (237.52 KB, image/png)
2012-04-09 14:33 UTC, Laurent BP
Details
Drawing saved with LibO 3.4.6 (10.40 KB, application/vnd.oasis.opendocument.graphics)
2012-04-10 13:51 UTC, Laurent BP
Details
Drawing saved with LibO 3.5.2 (10.43 KB, application/vnd.oasis.opendocument.graphics)
2012-04-10 13:53 UTC, Laurent BP
Details
Zip with theme's files (9.99 KB, application/zip)
2012-04-10 13:57 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2012-04-09 14:33:04 UTC
Created attachment 59700 [details]
Screenshot of clipart badly inserted in LibO 3.5

Problem description: 

Steps to reproduce:
1. Install extension "Gallery of danger signs"
http://extensions.libreoffice.org/extension-center/gallery-of-danger-signs
2. Restart LibO
3. Open Gallery
4. Select "Signalétique Chemical Product" Theme
5. Drag and drop first clipart (GHS-general)


Current behavior:
=> with LibO from 3.5.0 the different elements of the clipart are separated (check screenshot)


Expected behavior:
=> with LibO up to 3.4.6 the clipart is correctly inserted, with the same look as in the Gallery

However, the bug does not apply to all cliparts. I could not identify what makes wrong exactly.
I expected it was the same as issue 47699 or issue 47406, but it is NOT the case :( 
The Gallery, which is one of the most popular extension, is almost unusable with LibO 3.5. Must keep 3.4.6.

Platform (if different from the browser): Win7
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Laurent BP 2012-04-09 22:37:29 UTC
Confirmed on WinXP
Comment 2 Rainer Bielefeld Retired 2012-04-09 23:03:56 UTC
[Reproducible] with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit).

I thought that this one might be a DUP of "Bug 43752 - VIEWING: Rotated flipped shapes in 3.4 drawings loose rotation opened in 3.5", but the problem here is 
NOT fixed with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 4495824-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-08 00:03:52).

I did not check where the problem appeared.

@rodo:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 3 Jean-Baptiste Faure 2012-04-09 23:53:56 UTC
Confirmed on Linux / Ubuntu 11.10 x86_64 with:
LO 3.5.2 : LibreOffice 3.5.2.2 Version ID : 281b639-6baa1d3-ef66a77-d866f25-f36d45f
LO 3.5.3 rc0+ : LibreOffice 3.5.3rc0+ Version ID : d2e74fc-a73d29c-6845e52-f269e46-31eca31
Master : LibreOffice 3.6.0alpha0+ Build ID: f55eed2-d8a4706-6299bf6-ec86456-186d9e

Set platform and OS to All.

Best regards. JBF
Comment 4 Laurent BP 2012-04-10 13:50:13 UTC
In order to simplify the procedure, here's a new one:
* In LibO 3.4.6
- open skull346.odg (it was saved in LibO 3.4.6 from original drawing of the gallery)
- create a theme "skull"
- long-click then drag and drop in skull's theme 
- rename the clipart in the gallery in import346
- close LibO 3.4.6
- in user profile copy theme's files sgxxx.sdv, sgxxx.thm and sgxxx.sdg
* In LibO 3.5.2 
- paste theme's files in user profile
- open file skull346.odg => drawing looks OK
- drag and drop from skull's theme => ERROR

Inverted procedure:
* In LibO 3.5.2 
- open skull352.odg (it was saved in LibO 3.5.2 from original drawing of the gallery)
- long-click then drag and drop in skull's theme 
- rename the clipart in the gallery in import352
- close LibO 3.5.2
- in user profile copy theme's files sgxxx.sdv, sgxxx.thm and sgxxx.sdg
* In LibO 3.4.6 
- paste theme's files in user profile
- open file skull352.odg => ERROR drawing looks bad: cf. bug 47699, comment 7
- drag and drop from skull's theme: import346=>OK; import352 => ERROR

Next attachments: odg files and zip with theme's files
Comment 5 Laurent BP 2012-04-10 13:51:48 UTC
Created attachment 59779 [details]
Drawing saved with LibO 3.4.6

This drawing is correctly imported in LibO 3.4.6 and 3.5.2
Comment 6 Laurent BP 2012-04-10 13:53:45 UTC
Created attachment 59780 [details]
Drawing saved with LibO 3.5.2

This file is correctly opened in LibO 3.5.2 but NOT in LibO 3.4.6
Comment 7 Laurent BP 2012-04-10 13:57:29 UTC
Created attachment 59781 [details]
Zip with theme's files

First clipart (import346) was imported from LibO 3.4.6 => it is correctly inserted in LibO 3.4.6 but NOT in 3.5.2
Second clipart (import352) was imported from LibO 3.5.2 => it is NOT correctly inserted in LibO 3.4.6 but correctly in 3.5.2
Comment 8 Laurent BP 2013-05-22 20:28:19 UTC

*** This bug has been marked as a duplicate of bug 47406 ***