Bug 48553 - default grouping for text animations in custom animations should be "As one object"
Summary: default grouping for text animations in custom animations should be "As one o...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 48554 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-11 05:25 UTC by Christoph Anton Mitterer
Modified: 2015-07-25 01:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Anton Mitterer 2012-04-11 05:25:30 UTC
Hi.

Since (I guess) LibreOffice 2.5 it's possible that for effects on text, each paragraph of a single text object gets its own animation settings and and own entry in the tree of the animations (I mean the UI control box).

The default seems now to be that you get all paragraphs separated with own effect settings, i.e. the "All paragraphs at once"[0] setting.....

I guess the better default would be that the whole text object is taken as one effect object (i.e. the "As one object" setting).
This seems to be more naturally, when you select a object (i.e. the whole text object) for being animated.


Cheers,
Chris.

[0] btw: shouldn't that read better something like "Each paragraph separately"
Comment 1 A (Andy) 2013-02-16 10:01:20 UTC
*** Bug 48554 has been marked as a duplicate of this bug. ***
Comment 2 Joel Madero 2014-05-21 16:44:59 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+ Build ID: 84862db95a5e22b9ef89baa2a8a5deeffefbdef6
Date:   Thu Apr 24 21:43:16 2014 +0300
Platform: Ubuntu Linux 14.04 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Medium

Whiteboard Status - NeedsDevEval

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Thorsten Behrens (allotropia) 2014-11-05 22:34:05 UTC
I think this got changed during the 'sensible defaults' UX project in OpenOffice.org times; as such I wonder if it's really sensible to change it back?

The rationale IIRC was, that the natural 'this text appears on a click' is to have each talking point appear individually. For my use of presentations, I would agree with that approach.
Comment 4 Joel Madero 2014-11-05 22:38:09 UTC
Sounds reasonable - for issues like these where there are reasonable opinions on both side it turns into an endless debate. As this was changed in OOo days for particular reasons that are sound, closing as WONTFIX. Thanks Thorsten