Bug 48597 - Calc cell content starting with Thai character is right-aligned by default
Summary: Calc cell content starting with Thai character is right-aligned by default
Status: RESOLVED DUPLICATE of bug 48431
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 04:18 UTC by panyazone
Modified: 2012-04-20 00:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description panyazone 2012-04-12 04:18:39 UTC
Thai character strings or mixed Thai-English strings starting with Thai character are displayed in Calc cell as right-aligned by default. Thai text in the cell should be left-aligned by default like English or other Western language.

To work around this bug, one need to format all the cells as left-aligned to display the content as it should be, which is quite a burden. This problem does not exist in OpenOffie 3.3.

To investigate this bug, copy and paste either of the following two character strings, paste into a cell, hit Enter key, and see the alignment of the cell content.

สวัสดี

ก English texts starting with a single Thai character.
Comment 1 Korrawit Pruegsanusak 2012-04-17 03:04:34 UTC
I think this is the same cause as bug 48431, so mark as duplicate.

*** This bug has been marked as a duplicate of bug 48431 ***
Comment 2 panyazone 2012-04-20 00:03:42 UTC
It is the same as the last part of the original report of Bug 48431. Confirmed it's a duplicate. Awiting for 3.5.3 to see this bug fixed.