Download it now!
Bug 48431 - FORMATTING: All positive currency cells go blank
Summary: FORMATTING: All positive currency cells go blank
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All All
: high critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords: regression
: 47541 48372 48597 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-07 23:15 UTC by Banphot Nuchleang
Modified: 2012-04-17 05:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Focus the cell and a number on the bar. I have more screenshots if you want. (105.08 KB, image/png)
2012-04-07 23:15 UTC, Banphot Nuchleang
Details
My statistical money for years is blank! (101.21 KB, image/png)
2012-04-07 23:18 UTC, Banphot Nuchleang
Details
I feel frustrated with this sever bug. (106.97 KB, image/png)
2012-04-07 23:20 UTC, Banphot Nuchleang
Details
This is my original file (.ods) about accounting. (101.34 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-04-07 23:31 UTC, Banphot Nuchleang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Banphot Nuchleang 2012-04-07 23:15:49 UTC
Created attachment 59635 [details]
Focus the cell and a number on the bar. I have more screenshots if you want.

I have experienced <LibreOffice on Ubuntu> and <OpenOffice.org on Windows> for some time.
I have to work on the same documents and there was no problem in use.

But today, I removed OpenOffice.org from Windows and replaced with the latest LibreOffice.
I opened many documents for testing. It was almost okay like the old one.

The problem appears when I open an ODS (Calc spreadsheet) about daily accounting.
All cells containing POSITIVE number in CURRENCY format are BLANK!
Any pages, any sheets are blank!
Currency formulae that result in positive number are also blank too.

It shows only negative currency in red. As shown in attachment.
I have checked cell format settings but there is no unusual things.

However, the blankened numbers are still displayed on the top editting bar.
That means the numbers are still there but not to be shown.
This is not good if I cannot see any positive money in accounting sheet.
Please resolve this severe bug.



Secondary issue: why almost text cells are right-aligned by default?
The version on Ubuntu nor OpenOffice.org have never occured such issue.
Thai language is left-to-right writing like English, so this odd should not have happened.

FYI: My files are in Thai language and my computer is set under Thai locale.
Comment 1 Banphot Nuchleang 2012-04-07 23:18:36 UTC
Created attachment 59636 [details]
My statistical money for years is blank!
Comment 2 Banphot Nuchleang 2012-04-07 23:20:16 UTC
Created attachment 59637 [details]
I feel frustrated with this sever bug.
Comment 3 Banphot Nuchleang 2012-04-07 23:31:03 UTC
Created attachment 59638 [details]
This is my original file (.ods) about accounting.
Comment 4 Banphot Nuchleang 2012-04-07 23:39:37 UTC
Installed from LibO_3.5.2_Win_x86_install_multi.msi Thai
Comment 5 Eike Rathke 2012-04-14 06:33:49 UTC
Reproduced on Linux master 3.6 en_US locale.
Comment 6 Eike Rathke 2012-04-14 15:08:06 UTC
@kohei:
This regression was introduced with 66778dd58d69426d527edd6ea5d847ce62c950ac as an attempt to fix bug 32530.
It happens if the output string for a numeric value starts with a Baht symbol (or any other Thai character for that matter) and the script type of that first character is taken to determine the horizontal alignment.
Comment 7 Eike Rathke 2012-04-14 15:09:59 UTC
*** Bug 48372 has been marked as a duplicate of this bug. ***
Comment 8 Korrawit Pruegsanusak 2012-04-15 01:33:48 UTC
*** Bug 47541 has been marked as a duplicate of this bug. ***
Comment 9 Kohei Yoshida 2012-04-16 17:43:51 UTC
Eike, is there an easy way to determine the language of an arbitrary string?
Comment 10 Kohei Yoshida 2012-04-16 17:50:48 UTC
I might try i18n::XCharacterClassification::getCharacterDirection() to see if a given string is RTL or LTR, instead of getting its script type.  That method might be more reliable.
Comment 11 Not Assigned 2012-04-16 19:07:15 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e57525b61af70a6ee33c26f979e724740cca8655

fdo#48431: More reliable way to check for RTL text.
Comment 12 Kohei Yoshida 2012-04-16 19:12:53 UTC
I used the method I mentioned in comment 10 to determine proper horizontal alignment in case the cell contains RTL text (either full or partial).  I've verified that the test document is now rendered correctly, and all the cells that were invisible are now visible.
Comment 13 Not Assigned 2012-04-17 02:42:25 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a028f6c1e7fb80a22002ad6fed1604dab327e36&g=libreoffice-3-5

fdo#48431: More reliable way to check for RTL text.


It will be available in LibreOffice 3.5.3.
Comment 14 Korrawit Pruegsanusak 2012-04-17 03:04:34 UTC
*** Bug 48597 has been marked as a duplicate of this bug. ***
Comment 15 Eike Rathke 2012-04-17 04:25:05 UTC
Yes, using getCharacterDirection() should be correct.
Comment 16 Kohei Yoshida 2012-04-17 05:27:24 UTC
Fixed.