Bug 48614 - Thai characters rendered incorrectly
Summary: Thai characters rendered incorrectly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 09:47 UTC by panyazone
Modified: 2015-06-15 12:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problem detail with sample character strings and screenshots (237.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-04-12 09:47 UTC, panyazone
Details
Example of prblem #2 in other area (121.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-29 05:17 UTC, panyazone
Details
screenshot in 3.6 - incorrect font, but texts could be read (7.96 KB, image/png)
2012-06-30 22:43 UTC, Korrawit Pruegsanusak
Details
Re-test with the new LibreOffice 3.5.5 (240.43 KB, application/vnd.oasis.opendocument.text)
2012-07-16 10:10 UTC, panyazone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description panyazone 2012-04-12 09:47:32 UTC
Created attachment 59867 [details]
Problem detail with sample character strings and screenshots

Some Thai and mixed Thai-English character strings are rendered incorrectly in display area other than within the cell, such as the Cell Input Line, the Input Line of 

"Rename Sheet" pop-up window, tab name, data selection area for Data Filter Tool, and Data Selection Area for Data Pivot Tool. There are two types of problems.

1. Some Thai character strings like those in cells A2 and A3, including longer strings starting with these strings such as those in B2 and B3, are displayed 

correctly** within the cell, but they are displayed with strange characters in display areas elsewhere.

2. Some Thai character strings like those in cells T1 – T4 are displayed correctly** within the cell, but they appear with backward tabbing in display areas elsewhere.

** In fact, display within the cell is not fully correct, since it is not left-aligned by default as reported in Bug 48597. This bug and Bug 48597 are reported 

separately since the problems occur in different areas, i.e., Bug 48597 occurs within cell area, and this bug in areas other than cell area.
Comment 1 Korrawit Pruegsanusak 2012-05-18 04:56:26 UTC
*Except* the text alignment problem (bug 48597) which is now solved:

[REPRODUCIBLE] in 3.5.4.1 Windows 7 as described in the file.

[REPRODUCIBLE] in Windows 7, Master build, tinderbox W2008R2@16-minimal_build, pull time 2012-05-18 00:57:37, Build ID: 3da4ab
In master build it has less problems for "คลิกที่ cell  ถ้าคีย์คำว่า" text, but other texts still have problem.

Related to bug 33090 ?
Comment 2 panyazone 2012-06-29 05:17:53 UTC
Created attachment 63603 [details]
Example of prblem #2 in other area
Comment 3 panyazone 2012-06-29 05:22:57 UTC
All reported problems are solved in LibreOffice 3.5.4 (release) version.

However, problem #2, backward tabbing of mixed Thai-English text strings, are found in new area not reported before, such as drop-down menu and various pop-up windows. See the second attachment dated 2012-06-29.
Comment 4 Korrawit Pruegsanusak 2012-06-30 22:31:29 UTC
(In reply to comment #3)
> All reported problems are solved in LibreOffice 3.5.4 (release) version.

On Windows 7, the problem still REPRODUCIBLE for me in two following builds:

1) official 3.5.4.2 (release)
2) tinderbox W2008R2@16-minimal_build, branch MASTER, pull time 2012-06-27 04:02:20, core:3f135598fd508e70f31f36cd8a8d7a61ccf4ff79
Comment 5 Korrawit Pruegsanusak 2012-06-30 22:43:55 UTC
Created attachment 63658 [details]
screenshot in 3.6 - incorrect font, but texts could be read

However, on Windows 7, libreoffice-3-6 daily build 3.6.0.0.beta2+, from Win-x86_9-Voreppe, pull time 2012-06-28 19:36:32, core: 55d095a3122f68ebf97fd9b2567173c7fb648761

In input bar, the texts could be read, but with incorrect font, see screenshot.
I *think* this is caused by some configuration, maybe during the build or runtime configuration.

@panyazone, did your "problem fixed in 3.5.4 release" is same as this screenshot?
Comment 6 panyazone 2012-07-12 06:02:02 UTC
Apologies for my inaccurate Comment 3 and taking so long to come back. I'd like to correct it as follows.

When testing with Windows XP, all reported problems are solved in LibreOffice 3.5.4 (release) version. But all the problems are reproducible in Windows 7.

Anyway, I still confirm the new problem report in Comment 3, backward tabbing of mixed Thai-English text strings, are found in new area not reported before, such as drop-down menu and various pop-up windows. See the second attachment dated 2012-06-29.
Comment 7 panyazone 2012-07-16 10:10:17 UTC
Created attachment 64268 [details]
Re-test with the new LibreOffice 3.5.5

I have tested the new LibreOffice 3.5.5 (release). No problem for test under Windows XP, but the problems still exist for Windows 7. To my surprise, Thai character rendering is in some case corrected by changing the User Interface Scaling as described in my new attachment #4.

The reason for me to play with UI scaling is because the sheet name in Thai is displayed with a very small font which is hard to read. Increasing the UI scaling make it readable.
Comment 8 panyazone 2012-07-16 10:17:40 UTC
I should have said "Problem not exist in 3.5.4 release for Windows XP". Your screen shot and observation is delicate and might be overlooked by most poeple. It's unique, but I didn't encounter it so far. (In reply to comment #5)
> Created attachment 63658 [details]
> screenshot in 3.6 - incorrect font, but texts could be read
> 
> However, on Windows 7, libreoffice-3-6 daily build 3.6.0.0.beta2+, from
> Win-x86_9-Voreppe, pull time 2012-06-28 19:36:32, core:
> 55d095a3122f68ebf97fd9b2567173c7fb648761
> 
> In input bar, the texts could be read, but with incorrect font, see screenshot.
> I *think* this is caused by some configuration, maybe during the build or
> runtime configuration.
> 
> @panyazone, did your "problem fixed in 3.5.4 release" is same as this
> screenshot?
Comment 9 QA Administrators 2015-04-19 03:20:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 10 Buovjaga 2015-06-15 12:40:36 UTC
No problems with default settings. WFM. Set back to NEW, if still a problem for you.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)