Bug 48710 - FILESAVE: 'No Fill' picture background not retained when saving to .doc
Summary: FILESAVE: 'No Fill' picture background not retained when saving to .doc
Status: RESOLVED DUPLICATE of bug 132094
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2012-04-14 17:58 UTC by Christopher M. Penalver
Modified: 2020-06-16 18:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2012-04-14 17:58:47 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/873287

1) lsb_release -rd
Description:	Ubuntu precise (development branch)
Release:	12.04


2) apt-cache policy libreoffice-writerlibreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/873287/+attachment/2540085/+files/problematic%20document.doc -O inf.doc && lowriter -nologo inf.doc

select the picture at bottom right -> Format -> Picture -> Background tab -> No Fille -> OK -> Save as .doc -> Close -> Reopen and the No Fill persists.

4) What happens is it does not.

WORKAROUND: Save as .odt.
Comment 1 Teo91 2013-09-29 13:49:34 UTC
I can confirm this with LO 4.1.1. on Windows 7 SP1
Comment 2 Teo91 2013-09-29 13:50:32 UTC
Notice: AOO 4.0 works correctly.
Comment 3 Buovjaga 2014-10-21 10:30:03 UTC
Bug persists on Win 7 64-bit 4.3.2.2.

But on dev build there is no fill to begin with. Version: 4.4.0.0.alpha1+
Build ID: a8c24b25fd9fb21097a08a22797bf61b59099ea1
TinderBox: Win-x86@39, Branch:master, Time: 2014-10-21_06:33:33
Comment 4 Yousuf Philips (jay) (retired) 2014-10-21 10:50:58 UTC
Confirmed in 3.3.0, 3.6.7, 4.3.

Version: 4.3.4.0.0+
Build ID: bea74d73f4782b17f5286327f15db60ab3ae85de
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-10-15_05:34:17
Comment 5 Yousuf Philips (jay) (retired) 2014-10-21 10:58:17 UTC
(In reply to todventtu from comment #3)
> Bug persists on Win 7 64-bit 4.3.2.2.
> 
> But on dev build there is no fill to begin with. Version: 4.4.0.0.alpha1+
> Build ID: a8c24b25fd9fb21097a08a22797bf61b59099ea1
> TinderBox: Win-x86@39, Branch:master, Time: 2014-10-21_06:33:33

The bug of it opening in master with transparent fill is bug 85283.
Comment 6 Robinson Tryon (qubit) 2015-12-09 18:43:14 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2017-12-10 16:43:41 UTC Comment hidden (obsolete, spam)
Comment 8 QA Administrators 2019-12-11 03:37:12 UTC Comment hidden (obsolete, spam)
Comment 9 Justin L 2020-06-16 18:31:30 UTC
Fixed in LO 7.0 by commit 38e7e6f348df5d6b37d7e0051fd3b8c227db69e6
Author: Justin Luth on Tue Apr 14 17:39:36 2020 +0300

    tdf#132094 doc: fix export of fill in wrap-through fly frames
    
    This builds on commit 2f13dbac060ae6af7e25ad3eff675cc859cfb3ff
    by Miklos Vajna on  Fri Jun 15 08:49:46 2012 +0100
        n#325936 fix ww8 export of fly frames with transparent bg
    where he wisely and cautiously says
        Regression from commit ed8b5f2d -- to be safe, reverted only
        for fly frames in headers.
    because for some unknown reason, way back in 2002, commit
    ed8b5f2debac216243930aba0873e0d75de8d0dd forced all
    frames to specify a background fill. Typically of
    course this is white, and so who notices?
    
    Well, you notice if your frame is transparent, and
    now the area fill hides something that it is over top of.
    Like for example a transparent image, where the text wraps
    through the image.
    
    At first I was going to just try and revert everything.
    Then I decided it likely was a difference between how
    LO and MSO handled stacking/overlapping things.
    After that, I was going to just make an exception for
    eShapeType == mso_sptPictureFrame, but that only seems
    necessary if there is something underneath. If the something
    is just a background, that is handled anyway, so really
    it would only be other shapes or (most importantly) text,
    so the safest thing is testing wrap through, which there was
    already a pre-defined variable to reuse
    (and fix the spelling).

*** This bug has been marked as a duplicate of bug 132094 ***