Bug Hunting Session
Bug 48946 - not find JRE
Summary: not find JRE
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All Windows (All)
: highest blocker
Assignee: David Tardon
URL:
Whiteboard: target:3.6.0.0.beta1
Keywords: regression
: 49275 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-04-19 19:28 UTC by ape
Modified: 2012-08-03 04:12 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Base is not working (15.43 KB, image/png)
2012-04-24 22:52 UTC, ape
Details
Macro crash notification (4.49 KB, image/png)
2012-05-09 04:09 UTC, pz1
Details
Base_error (22.37 KB, image/png)
2012-06-03 05:42 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2012-04-19 19:28:07 UTC
LibO-3.6.0alpha0_Win86 (the window: "Options - LOdev - Java") can not find the JRE, installed into the operating system.
Comment 1 manj_k 2012-04-20 03:48:17 UTC
Confirmed on WinXP 32b w/ jre 1.6.0_31.

Tried via 'Add..' button w/o success.
Comment 2 manj_k 2012-04-20 04:06:00 UTC
Current version:
master~2012-04-17_23.05.35_LibO-Dev_3.6.0alpha0_Win_x86

tinderbox: buildname: Win-x86@6-fast
tinderbox: tree: MASTER
tinderbox: pull time 2012-04-17 23:05:35
tinderbox: git sha1s
core:66974653c0635e9e13a277e22da33e7f2062e674
binfilter:af20ea3f8376a9d29d00d06b106fc49ca85377af
dictionaries:05f89ef6371a108ebc4e7763541407a2552ab274
help:ae7aae4e8962cb1256a785dad57bc8ce697b993f


I don't remember the first occurrence. 
But the following version has been affected, too:

master~2012-04-01_22.12.31_LibO-Dev_3.6.0alpha0_Win_x86

tinderbox: buildname: Win-x86@6-fast
tinderbox: tree: MASTER
tinderbox: pull time 2012-04-01 22:12:31
tinderbox: git sha1s
core:4ab9719f15baddbc60b96d86d2e0878e79a6ddf7
dictionaries:6299bf66e3004cb8db805b360070762d0870cf50
help:879ce369d7f292c50886019a5a8573c316dc8cd5
Comment 3 ape 2012-04-24 22:52:34 UTC
Created attachment 60553 [details]
Base is not working

LOdev-3.6.0alpha0+_Win_x86 (build ID: 52d90ce)
OS: Windows-7sp1_x32; Windows-XPsp2_x64
This error does not allow Base will work  - the status of "blocking" for this reason.
Comment 4 manj_k 2012-04-29 11:02:57 UTC
*** Bug 49275 has been marked as a duplicate of this bug. ***
Comment 5 pz1 2012-05-09 04:09:26 UTC
Created attachment 61275 [details]
Macro crash notification

My macros started from a user defined Menu entry do crash because Java Virtual Machine can not be found. I can confirm the findings of previous posters w.r.t. WinXP and Win7
Comment 6 Sergey 2012-05-10 03:52:24 UTC
version 3.6.0alpha0+ (Build ID: 7f3f6e4) on WinXP:
1) Was not able to autodetect JRE.
2) Tools->Options->Java: no JRE listed
3) Tools->Options->Java: click add, in the path select dialog provide path to the installed JRE folder, click Ok, path selection dialog disappears and reappears again immediately. Nothing more happens.
Comment 7 Sergey 2012-05-10 03:53:07 UTC
Are there any log files for us to look into?
Comment 8 pz1 2012-05-12 03:16:07 UTC
(In reply to comment #7)
> Are there any log files for us to look into?

Well, my screendump says on a macrocrash:

com.sun.star.uno.RuntimeExceptionProviderCache::populateCache: couldn't obtain XSingleComponentFactory for [JavaVirtualMachine]: An unexpected error occurred while searching fo a Java!

Hope this may help the debuggers. I have no serious programming skils myself, so I am stuck here.
Remains strange that no one has picked up this 'Blocker'. It stops me from thoroughly testing the patch that was made for faulty Table Autoformats.
Comment 9 Julien Nabet 2012-05-16 15:28:21 UTC
With the most updated master sources and a brand new LO profile, could you try to retrieve an useful backtrace by following this great video ?
http://www.youtube.com/watch?v=fppBTs215yc
It could really help a lot the devs.
Comment 10 pz1 2012-05-16 23:53:55 UTC
(In reply to comment #9)
> With the most updated master sources and a brand new LO profile, could you try
> to retrieve an useful backtrace by following this great video ?
> http://www.youtube.com/watch?v=fppBTs215yc
> It could really help a lot the devs.

Nothing stops you from just doing that, and publish the results here!
Comment 11 Julien Nabet 2012-05-17 00:51:06 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > With the most updated master sources and a brand new LO profile, could you try
> > to retrieve an useful backtrace by following this great video ?
> > http://www.youtube.com/watch?v=fppBTs215yc
> > It could really help a lot the devs.
> 
> Nothing stops you from just doing that, and publish the results here!
Nothing at all, you're right except that I'm on Linux most of the time and try to give bt with symbols on this system.
Now nobody forces you to do it :-)
Comment 12 manj_k 2012-05-18 08:02:42 UTC
Added keyword 'regression'
Comment 13 Rainer Bielefeld Retired 2012-05-29 09:43:10 UTC
This bug is NEW,
<https://wiki.documentfoundation.org/QA-FAQ#How_to_use_Status_or_Keyword_NEEDINFO>
Comment 14 ljelly 2012-05-31 02:32:35 UTC
same problem with finding java on windows 8 CP.

as outlined above about finding java.

ljelly.
Comment 15 DavidO 2012-06-03 04:48:17 UTC
I looked at it and it turns out, that it was failing in ./jvmfwk/source/fwkbase.cxx:181 with:

The file: vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/libsunjavaplugin.dll does not exist."
But the Library is called sunjavaplugin.dll and not libsunjavaplugin.dll.

So we have really simple workaround for Alpha1:
go to
%INSTALL_DIR_LO_ALPHA1%\URE\misc\javavendors.xml

replace
  <library vendor="Sun Microsystems Inc.">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/libsunjavaplugin.dll</library>
  <library vendor="Oracle Corporation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/libsunjavaplugin.dll</library>
  <library vendor="IBM Corporation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/libsunjavaplugin.dll</library>

through:
sunjavaplugin.dll

  <library vendor="Sun Microsystems Inc.">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.dll</library>
  <library vendor="Oracle Corporation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.dll</library>
  <library vendor="IBM Corporation">vnd.sun.star.expand:$URE_INTERNAL_LIB_DIR/sunjavaplugin.dll</library>

LO -> Java Bridge is working now.
Comment 16 David Tardon 2012-06-03 05:30:56 UTC
(In reply to comment #15)
> So we have really simple workaround for Alpha1:
> ...
> 
> LO -> Java Bridge is working now.

Now you broke it on Linux and MacOS X :-)

Sorry, this is my fault. The library was named sunjavaplugin originally; I renamed it during gbuildization of jvmfwk because the name did not fit any library naming scheme we had and did not realize that would cause problems on Windows. I will change the name back and mangle it in RepositoryFixes.mk .
Comment 17 ape 2012-06-03 05:42:45 UTC
Created attachment 62447 [details]
Base_error

Well, LOdev-3.6.0alpha1_Win-x86 finds the path to the JRE now. But the connection to the tables in LOdev_Base impossible still. See the snapshot in the attachment.
Comment 18 Not Assigned 2012-06-03 05:56:05 UTC
David Ostrovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=faaa021635a6a731d920dee5d929f6e3e459cb77

fdo#48946: URE_INTERNAL_LIB_DIR/libsunjavaplugin.dll does not exist.
Comment 19 David Tardon 2012-06-03 06:35:18 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > So we have really simple workaround for Alpha1:
> > ...
> > 
> > LO -> Java Bridge is working now.
> 
> Now you broke it on Linux and MacOS X :-)

I take that back. I forgot there is more than one javavendors_<platform>.xml file, so Windows-specific change can be done without affecting other platforms.

Therefore the fix is good and nothing more is needed.
Comment 20 manj_k 2012-06-03 07:57:02 UTC
(In reply to comment #15)
>
> [...] So we have really simple workaround for Alpha1 [...]
> 
> LO -> Java Bridge is working now.


Thanks, works fine (on WinXP 32b) w/

- LibO 3.6.0alpha1 (Build ID: 66f01b5)

- LibO-Dev_3.6.0alpha1
Win-x86@6-fast MASTER
pull time 2012-06-01 00:20:15
core:76f63f4c9b324de9a6d2e1de1c6f718a153feb26

- LibO-Dev_3.6.0alpha0
Win-x86@6-fast MASTER
pull time 2012-04-17 23:05:35
core:66974653c0635e9e13a277e22da33e7f2062e674