Bug Hunting Session
Bug 49035 - Problems with recognizing Chinese fonts when running PDF export in headless mode
Summary: Problems with recognizing Chinese fonts when running PDF export in headless mode
Status: RESOLVED DUPLICATE of bug 51693
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-21 03:16 UTC by Sam
Modified: 2012-09-27 12:34 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam 2012-04-21 03:16:15 UTC
Same issue reported here: https://issues.apache.org/ooo/show_bug.cgi?id=111292

It seems like the headless mode does not know how to properly auto-substitute fonts. If you create a docx document with Chinese characters and use a font like Arial Unicode MS (a font that does not exist on my Linux system). Headless mode will churn out a PDF with square blocks.

But, if I open the document in GUI mode, the program knows how to substitute the unknown font for something that exist in my system.
Comment 1 Sam 2012-04-21 03:17:47 UTC
This also applies for Japanese. And I suspect this affects all East Asian languages.
Comment 2 Alexis de Lattre 2012-09-20 14:44:19 UTC
We are also affected by this bug with Libreoffice 3.5.3 on Linux.
Comment 3 Cédric Bosdonnat 2012-09-27 12:34:44 UTC
duplicate. Just checked with master: works fine.

*** This bug has been marked as a duplicate of bug 51693 ***