Bug Hunting Session
Bug 51693 - : [PATCH] Glyph substitutions of Chinese characters seldom work in Linux without fontconfig replacements activated
Summary: : [PATCH] Glyph substitutions of Chinese characters seldom work in Linux with...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.7.0
Keywords:
: 49035 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-03 08:07 UTC by Lubomir Rintel
Modified: 2012-09-27 12:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
[PATCH 1/2] Fall back to AR PL UMing CN for zh-cn text (2.01 KB, text/plain)
2012-07-03 08:09 UTC, Lubomir Rintel
Details
[PATCH 2/2] Fall back to AR PL UMing variants on presentation and spreadsheet, etc. as well (10.72 KB, text/plain)
2012-07-03 08:09 UTC, Lubomir Rintel
Details
maybe this would work better ? (1.15 KB, patch)
2012-07-03 09:03 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lubomir Rintel 2012-07-03 08:07:57 UTC
Problem description: 

On a stock RHEL (6) installation, when OpenOffice.org runs in headless mode (effectively disabling fontconfig), Chinese characters included in Latin texts don't get replaced with UMing family glyphs (which is the Chinese font of choice in RHEL and other Linux distributions).

Situation seemed to improve in a later LibreOffice commit that added some UMing substitution, but that was not quite sufficient (did not work in spreadsheet with zh-cn characters) for me.

I'm including the patches with changes I've done to make things work for me with some guesswork and attempts to be consistent across Chinese variants.
Comment 1 Lubomir Rintel 2012-07-03 08:09:17 UTC
Created attachment 63769 [details]
[PATCH 1/2] Fall back to AR PL UMing CN for zh-cn text
Comment 2 Lubomir Rintel 2012-07-03 08:09:36 UTC
Created attachment 63770 [details]
[PATCH 2/2] Fall back to AR PL UMing variants on presentation and spreadsheet, etc. as well
Comment 3 Caolán McNamara 2012-07-03 09:03:23 UTC
Created attachment 63772 [details]
maybe this would work better ?

Are you able to test this patch ? i.e. enable fontconfig font and glyph substitution for the headless case. It it works that'd be the ideal solution methinks.
Comment 4 Not Assigned 2012-07-03 13:33:32 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=871111155e302ecaf245003bcd8357e294f8b268

Resolves: fdo#51693 use fontconfig font/glyph substitution in headless mode
Comment 5 Caolán McNamara 2012-07-03 13:35:14 UTC
hopefully that fixes it by using fontconfig replacements on headless mode too
Comment 6 Cédric Bosdonnat 2012-09-27 12:34:44 UTC
*** Bug 49035 has been marked as a duplicate of this bug. ***