Download it now!
Bug 49183 - MinGW: Windows resources (.res) are not linked to executables
Summary: MinGW: Windows resources (.res) are not linked to executables
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:3.6.0
Keywords:
: 42027 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-26 10:39 UTC by Rainer Bielefeld Retired
Modified: 2012-05-02 04:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-04-26 10:39:07 UTC
"master~2012-04-26_00.37.10_LibO-Dev_3.6.0alpha0_Win_x86_install-arc_en-US.tar.gz" contains an incomplete soffice.bin, size only 87kB. Replacing with soffice.bin from LibO 3.5.3RC2 (666 kB) heals the problem.
Comment 1 Rainer Bielefeld Retired 2012-04-26 10:41:23 UTC
EasyHack?
Comment 2 Andras Timar 2012-05-01 02:57:47 UTC
@Rainer, the resource section is missing from all Windows executables when they are built with MinGW, it must be a problem with the platform specific makefile. 

@David, Windows resources are generated in WinResTarget but they are not linked to the executables. It never worked under MinGW.
Comment 3 Not Assigned 2012-05-02 01:57:45 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=602f251d6c5f1f5551cdeb4c70abe0c49834d2c7

fdo#49183 link resources to executables
Comment 4 Andras Timar 2012-05-02 04:30:22 UTC
*** Bug 42027 has been marked as a duplicate of this bug. ***