Bug Hunting Session
Bug 42027 - MinGW: Desktop Icon "Installer" instead of LibO, all icons missing in executables.
Summary: MinGW: Desktop Icon "Installer" instead of LibO, all icons missing in executa...
Status: RESOLVED DUPLICATE of bug 49183
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium minor
Assignee: Jan Holesovsky
URL:
Whiteboard: BSA
Keywords:
: 41898 (view as bug list)
Depends on:
Blocks: mabMinGW
  Show dependency treegraph
 
Reported: 2011-10-19 21:51 UTC by Rainer Bielefeld Retired
Modified: 2012-05-02 04:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot Desktop Icon (52.28 KB, image/png)
2011-10-19 21:51 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-10-19 21:51:55 UTC
Created attachment 52564 [details]
Screenshot Desktop Icon

Steps how to reproduce with Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  308b7a2-e916bf9-9c6ea62-e1a2fb3)] (daily/MinGW_cross-compilation 2011-10-18_22.56.49)"

1.Download and unpack current MinGW Windows build
2. Create a Destop link icon using 'Right click on 
   Desktop -> New  -> Link'
   Expected: LibO Icon
   Actual: Installer Icon
Comment 1 Rainer Bielefeld Retired 2011-11-03 07:52:32 UTC
As discussed during TSC call: Blocks "Bug 41883 MinGW port Most Annoying Bugs"
Comment 2 Rainer Bielefeld Retired 2011-11-14 13:23:37 UTC
*** Bug 41898 has been marked as a duplicate of this bug. ***
Comment 3 Rainer Bielefeld Retired 2011-11-15 22:33:26 UTC
*** Bug 41898 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2011-11-16 00:06:44 UTC
Confirmed by Bug 41898.

Still a problem with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  7ba7cba-5d03837-adcf6d5-c4bb9bd)] (daily/MinGW_cross-compilation2011-11-26_02.11.53)".

I can not confirm pedlino's result that also MSVC is affected, executables of Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  d38713d-5d03837-ca7e6f5-c4bb9bd-ce71330)]" (Voreppe 111115) are shown with correct icon in WIN Explorer.

@Jan:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Pedro 2011-11-16 03:03:39 UTC
I found out why the icons are not displayed: they are not included in the exes :)

Each MSVC exe has embedded the application icon, except for soffice.exe which contains the icons for all the LO applications
(with a lot of redundancy https://bugs.freedesktop.org/show_bug.cgi?id=42980)

The MinGW exes don't contain any icons.
Comment 6 Andras Timar 2012-05-02 04:30:22 UTC

*** This bug has been marked as a duplicate of bug 49183 ***