Bug Hunting Session
Bug 49229 - FILESAVE: OLE objects equations lost after saving particular .docx
Summary: FILESAVE: OLE objects equations lost after saving particular .docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-27 11:20 UTC by ale.carrazzoni
Modified: 2015-12-21 11:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
tabla_normal.docx (38.43 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-04-27 11:20 UTC, ale.carrazzoni
Details
tabla_normal.docx after being saved (13.20 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-04-27 11:21 UTC, ale.carrazzoni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ale.carrazzoni 2012-04-27 11:20:38 UTC
Created attachment 60704 [details]
tabla_normal.docx

On LibreOffice 3.5.2 Linux, after saving the tabla_normal.docx file in the same format, the equations are lost. The background of the tables is also white instead of being transparent, and the size of the cells seems to be different, causing some of the numbers on the table to be in two lines instead of one.

Steps to reproduce:
1. Open tabla_normal.docx file attached
2. Save it on the same format
3. Close LibreOffice and open the file again.

I'm also attaching tabla_normal 2.docx, which is the result of saving tabla_normal.docx in this way.
Comment 1 ale.carrazzoni 2012-04-27 11:21:21 UTC
Created attachment 60705 [details]
tabla_normal.docx after being saved
Comment 2 Cody 2012-04-28 15:15:16 UTC
LibreOffice 3.5.2.2
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45
Running on Windows 7, 64 bit edition

When saving the document tabla_normal.docx as specified, LibreOffice Writer prompts the user that the document contains content/formatting that cannot be saved in the currently selected format. Continuing to save in the same format will yield the same results; however using the ODF format will save the content/formatting appropriately.
Comment 3 ale.carrazzoni 2012-04-28 15:44:55 UTC
(In reply to comment #2)
> LibreOffice 3.5.2.2
> Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45
> Running on Windows 7, 64 bit edition
> 
> When saving the document tabla_normal.docx as specified, LibreOffice Writer
> prompts the user that the document contains content/formatting that cannot be
> saved in the currently selected format. Continuing to save in the same format
> will yield the same results; however using the ODF format will save the
> content/formatting appropriately.

The message prompt is the same one that is displayed ALWAYS when saving to a .doc or .docx file. I tried saving this file to the old .doc format and the same message is displayed even if the images were not lost after saving to that format. 
Warning a user that there MAY be data loss does not excuse not fixing bugs that cause data loss, especially those caused by poor reverse engineering of a format that almost everyone uses. If nobody wants to improve compatibility with .docx, then at the very least saving .docx files should be disabled on stable versions since it's not even in alpha state.
Comment 4 ale.carrazzoni 2012-04-28 20:23:48 UTC
I've found out that the reason none of the equations and images on that file are saved on .docx is that they're all OLE objects. It seems LibreOffice can't save those objects to .docx.
Comment 5 Rainer Bielefeld Retired 2012-07-04 04:08:57 UTC
[Reproducible] with reporter's sample and "LibreOffice  3.5.5.3.  German UI/Locale [Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21] on German WIN7 Home Premium (64bit) 

(MS-Specific?) Math object lost
Also a Picture object lost.
It seems more or less all objects will be lost when save as .docx

@Reporter:
The sample document has been created with MS Office?
What kind of objects are in the document?
Comment 6 ale.carrazzoni 2012-07-04 13:03:18 UTC
I think the document was created with MS Office, I'm not sure. There are two images, an equation and two tables. The tables aren't lost.
Comment 7 Rainer Bielefeld Retired 2012-07-14 10:04:53 UTC
@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 8 Cédric Bosdonnat 2014-01-20 08:57:02 UTC
Restricted my LibreOffice hacking area
Comment 9 tommy27 2014-04-30 20:30:04 UTC
issue confirmed in LibO 4.2.3.3 under Win7x64: all equations lost after saving and reloading.

equations not lost using 4.3.0.0.alpha0+ (*), however those equations are loaded in different position than 4.2.x and saved with lower resolution in respect to source .docx

(*) Build ID: 870ce1188ef7bfb6e57eed2894a20b2ea30b2225
TinderBox: Win-x86@39, Branch:master, Time: 2014-04-22_00:13:36

probably related to Bug 51550 (maybe a duplicate?)
Comment 10 Timur 2014-11-03 14:09:53 UTC
Original DOCX is not 100% correctly imported because the 3rd equation is in the table and it should be above the table. If we disregard this, because it can be moved), current status is as follows.

 (In reply to ale.carrazzoni from comment #0)
> On LibreOffice 3.5.2 Linux, after saving the tabla_normal.docx file in the
> same format, the equations are lost. The background of the tables is also
> white instead of being transparent, and the size of the cells seems to be
> different, causing some of the numbers on the table to be in two lines
> instead of one.

1. Bug 51550 was about problem with saving OLE objects, and now they can be saved only as images, but that's not the case here. Tested with LO 4.3.3, all 3 equations are saved, so NOT reproduced. 
2. "The background of the tables is also white instead of being transparent" is REPRODUCED. So I suggest title be changed to "FILESAVE: table background changed from transparent when saved as DOCX".
3. "some of the numbers on the table to be in two lines instead of one" NOT reproduced.
4. I'd say that we have here also Bug 69647: DOCX import of text and picture (shape?) (wrap involved?) have wrong spacing between them. 
Somehow, shapes that have wrap option loose it on import.
Comment 11 Timur 2014-11-03 14:47:41 UTC
> 2. "The background of the tables is also white instead of being transparent"
> is REPRODUCED. So I suggest title be changed to "FILESAVE: table background
> changed from transparent when saved as DOCX".
Or, maybe better, new bug report may be open for this. If it doesn't exist already, I could find only Bug 34585.
Comment 12 QA Administrators 2015-12-20 16:09:49 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 13 ale.carrazzoni 2015-12-20 16:36:25 UTC
The equations are no longer lost after saving in Libreoffice 5.0.4 Linux, but they are positioned wrong after saving.
Comment 14 tommy27 2015-12-20 17:11:49 UTC
thanks 4 feedback.

please open a new bug report about the residual issue
Comment 15 Timur 2015-12-21 11:34:46 UTC
Residual issues are:
-  "The background of the tables is white instead of being transparent on save": tables is no-fill, I don't know if that's the same as Bug 34585
- "equations are positioned wrong after saving": equations are anchored "to character" in recent versions, but are still saved "as character"

Additional search is advised before reporting as new bugs.