Download it now!
Bug 49407 - FORMATTING: Lack of "Font Effects" in Draw
Summary: FORMATTING: Lack of "Font Effects" in Draw
Status: RESOLVED DUPLICATE of bug 91932
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86 (IA32) All
: high enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 70829 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-02 16:24 UTC by mxpollo
Modified: 2016-06-14 17:32 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Effects dropdown menu missing in Calc. (217.86 KB, image/png)
2013-10-20 22:02 UTC, Peter Axup
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mxpollo 2012-05-02 16:24:31 UTC
NOT A BUG BUT A SUGGESTED ENHANCEMENT. Not able to use "Small Capitals" effect when formatting text in Draw. FONT EFFECTS dropdown list -which is available in Writer- is not included in Draw. Could this be considered to be included in later versions of Draw?

Where?

In Writer:

Format -> Character -> Font Effects -> Effects (dropdown list) -> Without, Capitals, Lowercase, Title, Small capitals

In Draw:

Format -> Character -> Font Effects -> (Effects dropdown list not here)
Comment 1 Joel Madero 2012-07-01 00:03:10 UTC
Yeah I think that this should be included and won't be too hard to include. Marking as NEW and making it HIGH priority as the code is already there, just needs to be brought into Draw. Furthermore, it would/should be uniform across all of the software packaged with LO. Thanks for the heads up on this one
Comment 2 zumbs 2013-01-15 20:23:04 UTC
Any news on this?
Comment 3 Paul-Antoine Arras 2013-04-17 16:04:33 UTC
This feature should be added to Draw, not only for obvious consistency reasons, but also for the sake of typographical correctness. There is no reason why presentations should not adhere to typography rules enforced in text documents.
For instance, in French, the speaker's last name (that generally appears on the first slide) would be typeset in small caps.
Comment 4 Jorendc 2013-10-20 21:30:11 UTC
*** Bug 70696 has been marked as a duplicate of this bug. ***
Comment 5 Jorendc 2013-10-20 21:32:09 UTC
See Bug 70696 . Also reproducible in Impress, so lets 'generalize' this bug. If someone is working on this bug, I don't think it's that big deal to fix both at once (no 2 separated bug reports/'projects'). If I'm wrong, please feel free to unduplicate it again.

Kind regards,
Joren
Comment 6 Peter Axup 2013-10-20 22:02:50 UTC
Created attachment 87904 [details]
Effects dropdown menu missing in Calc.
Comment 7 Peter Axup 2013-10-20 22:04:42 UTC
This is also reproducible in Calc.

Steps to reproduce:
1. Type a word in a cell and save it.
2. Select the word either in the Input Line or in the cell itself.
3. From the menu bar, select Format-Character, select the Font Effects tab, and see that the Effects dropdown menu is missing on the left side of the tab window, between the Font Color dropdown menu and the Relief dropdown menu.

Thank you,
Peter
Comment 8 Maxim Monastirsky 2014-10-27 20:22:47 UTC
*** Bug 85460 has been marked as a duplicate of this bug. ***
Comment 9 Maxim Monastirsky 2014-10-27 20:31:52 UTC
*** Bug 70829 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) (retired) 2014-10-28 08:33:39 UTC
Currently the drop down is visible in Impress/Draw and invisible in Calc. To me this is a bug and not an enhancement, as being able to modify a direct formatting or style option like this is mandatory.
Comment 11 Caolán McNamara 2015-06-08 12:26:42 UTC
Splitting this original bug about font effects missing in impress/draw and calc into the part for impress/draw (as bug 91932) and leaving this specifically for "font effects in calc". Note that excel doesn't (AFAIK) support the case map attribute
Comment 12 Heiko Tietze 2016-06-14 14:49:55 UTC
Caolán fixed the bug and closed tdf#91932 but not this one. Access to character properties is available from the sidebar and via main menu. And the font effects tab allows all types of font effect.
Comment 13 Maxim Monastirsky 2016-06-14 15:14:51 UTC
(In reply to Heiko Tietze from comment #12)
> Caolán fixed the bug and closed tdf#91932 but not this one. Access to
> character properties is available from the sidebar and via main menu. And
> the font effects tab allows all types of font effect.
No, this isn't fixed. The Effects dropdown (i.e. the one with Capitals, Lowercase etc.) is still disabled in Calc. And don't confuse this with the stuff in Format>Text menu. This is completely different thing technically.
Comment 14 Heiko Tietze 2016-06-14 16:05:06 UTC
(In reply to Maxim Monastirsky from comment #13)
> No, this isn't fixed. The Effects dropdown (i.e. the one with Capitals,
> Lowercase etc.) is still disabled in Calc. And don't confuse this with the
> stuff in Format>Text menu. This is completely different thing technically.

When I go to character properties via sidebar or main menu I can change the font effect to small capitals in Draw (this ticket is Draw, Calc has the field disabled). 

Close this bug and open another, or change the component?
Comment 15 Maxim Monastirsky 2016-06-14 17:32:52 UTC
(In reply to Heiko Tietze from comment #14)
> this ticket is Draw
You're right. The original report was about Draw, but later (comment 11) it was changed to Calc, but the Component field wasn't changed.

> Close this bug and open another, or change the component?
I think I'll close this one as a duplicate of bug 91932, and open a new clean report for Calc, as the current situation of reusing an originally Draw bug for Calc is just too confusing.

*** This bug has been marked as a duplicate of bug 91932 ***