Download it now!
Bug 49426 - DOCX import: Page number field uses the wrong font style (regular instead of bold)
Summary: DOCX import: Page number field uses the wrong font style (regular instead of ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2012-05-03 05:50 UTC by Tobias Burnus
Modified: 2015-04-25 14:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2012-05-03 05:50:12 UTC
Follow up to bug 37012.

The DOCX file (attachment 46479 [details]) contains a footer, which contains a frame with the page-number field (cf. bug 49425).

In Microsoft Word 2003 SP3, the page number is in "Arial (bold) 8pt".

In LibreOffice 3.5.1.2, the page number uses "Times New Roman (regular) 12pt".

(LO and MSO use "Arial (bold) 8pt" for the rest of the footer.)
Comment 1 Jean-Baptiste Faure 2012-05-06 08:44:24 UTC
Reproducible with current master (Build ID: 32af02b) under Ubuntu 11.10.

Best regards. JBF
Comment 2 Roman Eisele 2012-10-18 16:57:34 UTC
Improved Summary -- according to comment #0, not only the font size, also the font family is wrong.
Comment 3 Roman Eisele 2012-10-18 16:59:43 UTC
Still REPRODUCIBLE in LibreOffice 3.6.3.1 and in the last master build:
LOdev 3.7.0.0.alpha0+ (build ID: c252694; pull time: 2012-10-12 22:05:41),
both on Mac OS X 10.6.8 (Intel).
Comment 4 Jorendc 2013-12-28 23:13:04 UTC
Still reproducible using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 5be7ec4193b892e5643ff5f3f2e6755319569190
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-27_23:55:02

The page number is imported as "Arial (regular) 8pt". So behavior is improved. regular should be bold.

Changing summary accordingly.

Kind regards,
Joren
Comment 5 Jorendc 2013-12-28 23:30:30 UTC
I did some extra research:
Opened the attachment mentioned in the bug description using Microsoft Word 2010: the word 'DRAFT' is bold, the page number isn't.

So: is it a bug the field containing the page-number is not bold?
If not, this bug is fixed.

Kind regards,
Joren
Comment 6 QA Administrators 2015-04-19 03:21:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 7 Jean-Baptiste Faure 2015-04-25 14:32:18 UTC
Not reproducible anymore in LibreOffice 5.0.0.0.alpha1+ built at home under Ubuntu 14.10 x86-64. The page number is in Arial 8 as expected.

Closing as WorksForMe.

Best regards. JBF