Download it now!
Bug 49921 - UI: UI glitch in Find & Replace dialog - buttons invisible
Summary: UI: UI glitch in Find & Replace dialog - buttons invisible
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: BSA target:3.6.0
Keywords: regression
: 49624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-14 08:41 UTC by s-joyemusequna
Modified: 2012-05-19 08:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
UI defect in Find & Replace dialog (covered buttons marked in red) (43.29 KB, image/png)
2012-05-14 08:41 UTC, s-joyemusequna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description s-joyemusequna 2012-05-14 08:41:52 UTC
Created attachment 61632 [details]
UI defect in Find & Replace dialog (covered buttons marked in red)

Problem description: Find&Replace dialog - buttons invisible

Steps to reproduce:
1. Edit / Find & Replace: 
select "More Options" / "Format.." : tab [Font] is displayed, 4 buttons OK, Cancel, Help, and Reset are visible 
2. click tab "Indents & Spacing" => buttons are covered and they stay covered even if another tab is selected (s. attached picture)

Current behavior:
buttons not visible

Expected behavior:
buttons visible

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 s-joyemusequna 2012-05-14 08:46:43 UTC
Works for me with LibO 3.4.5 and LibO 3.5.1.

Seems to be new in LOdev 3.6 (master - 14-May-2012 02h55 x86@6-fast; Build ID: 347e345).

Tested under Windows Vista 64 and Windows XP.
Comment 2 s-joyemusequna 2012-05-14 08:55:36 UTC
Note: if the tab "Indents & Spacing" is the last used tab, LibO displays this tab on a new LibO start. All tabs have then the heigth of this tab and the error is not visible is this situation.
Comment 3 David Tardon 2012-05-14 23:25:37 UTC
Right. Miklos added a new checkbox to that tab page, which required changing its height. Unfortunately that means that heights of all other tab pages that might be used with combination with it need to be adjusted too. Oh, the joys of absolute positioning...
Comment 4 Not Assigned 2012-05-16 23:03:46 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f70fe6e651eefbc69c434256f7e74ad53519a36c

fdo#49921 make sure all tab pages have the same dimensions
Comment 5 s-joyemusequna 2012-05-18 12:10:47 UTC
Verified with LOdev 3.6 (master - 18-May-2012 02h44 x86@6-fast; Build ID: 8b1d29b) under Windows Vista 64.
Comment 6 Korrawit Pruegsanusak 2012-05-19 08:38:03 UTC
*** Bug 49624 has been marked as a duplicate of this bug. ***