Bug Hunting Session
Bug 50063 - CONFIGURATION: Assigning a keyboard shortcut to "Insert Hyperlink" maps it to "Edit Hyperlink"; assigning one to "Insert Insert Hyperlink" maps it to "Insert Hyperlink"
Summary: CONFIGURATION: Assigning a keyboard shortcut to "Insert Hyperlink" maps it to...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 60747 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-17 14:42 UTC by Taryn Fox
Modified: 2016-04-30 16:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots showing the same names for inser and edit hyperlinks (44.58 KB, application/vnd.oasis.opendocument.graphics)
2013-04-25 08:03 UTC, bugquestcontri
Details
updated screenshots (83.27 KB, application/vnd.oasis.opendocument.graphics)
2013-04-26 04:30 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Taryn Fox 2012-05-17 14:42:24 UTC
PROBLEM

In Tools -> Customize -> Keyboard, assigning a keyboard shortcut to the "Hyperlink" option on the "Insert" menu REALLY assigns it to "Edit Hyperlink". I.e. highlighting text and using that shortcut does nothing, but selecting a hyperlink you've already inserted and using it lets you edit that link.

If you want to assign a shortcut that lets you insert a completely new hyperlink, the option you're looking for is "Insert Hyperlink", which is inside the "Insert" menu a little ways down from "Hyperlink".

So to recap, "Insert Hyperlink" means "Edit Hyperlink," and if you want to insert a new hyperlink you want "Insert Insert Hyperlink". Which makes perfect sense ... or not.

HOW TO REPRODUCE

1. Open Tools -> Customize -> Keyboard.
2. Choose any unassigned keyboard shortcuts, and assign them to Insert -> Hyperlink and Insert -> Insert Hyperlink.
3. Test them out and see what happens.

EXPECTED BEHAVIOR

1. Insert -> Hyperlink will, in fact, insert a hyperlink.
2. If there needs to be a keyboard shortcut for editing an existing hyperlink, separate from the existing "Insert Hyperlink" option, it will be listed someplace more logical (like Edit -> Hyperlink).
3. Redundant- and confusing-sounding menu items like "Insert Insert Hyperlink" will not exist.

PLATFORM

Fedora 17 beta using GNOME 3.
Comment 1 Christina Rossmanith 2012-09-22 19:19:01 UTC
Reproducible with

Version 3.7.0.0.alpha0+ (Build ID: 784302d)
Comment 2 jd 2013-01-04 02:12:21 UTC
As a new LibreOffice user, I spent a bunch of time trying to figure out what I was doing wrong when trying to assign a keyboard shortcut for the Insert Hyperlink dialog.  Thank you for explaining the problem (I was about to file a bug report when I came across this one).
Comment 3 Brenda Granados 2013-02-27 17:29:08 UTC
*** Bug 60747 has been marked as a duplicate of this bug. ***
Comment 4 bugquestcontri 2013-04-25 00:51:28 UTC
A question in AskLibO (http://ask.libreoffice.org/en/question/16468/custom-keyboard-shortcut-not-working/?comment=16564#comment-16564) made me looking into my LibO Portable

tools / customize / keyboard / shortcuts

Observations:
When assigning a the short cut "insert" & "hyperlink" and "edit" & "hyperlink" the asssinged text says in both cases only "hyperlink"

When using the shortcut key for "insert hyperlink" nothing happens, when using the shortcut key for "edit hyperlink" the Hyperlink windows opens and I can insert or edit a hyperliink.

Requests
1 -Enable the the functionality "insert hyperlink" 
2 - Enable differentiation in the short cut menu list between "insert hyperlink" and "edit hyperlink" or display "insert & edit hyperlink" in the shortcut list


LibO: 
Version 3.6.6.2 (Build ID: f969faf)
and 
Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)

XP Pro / SP3
Comment 5 bugquestcontri 2013-04-25 08:03:29 UTC
Created attachment 78441 [details]
Screenshots showing the same names for inser and edit hyperlinks
Comment 6 bugquestcontri 2013-04-26 04:28:53 UTC
During the discussion in AskLibO I saw that my previous comment is not fully correct. Here are the needed corrections:

tools / customize / keyboard / shortcuts

Observations:
When assigning a the short cut "insert" & "hyperlink" and "edit" & "hyperlink" the asssinged text says in both cases only "hyperlink". Additionally there is the possibility to assigne a short cut "insert" & "insert hyperlink"

When using the shortcut key for
- "insert" & "hyperlink" nothing happens, 
- "edit" & "hyperlink"  the Hyperlink windows opens 
- "insert" & "insert hyperlink" the Character window opens

Updated screen shots are added.

Requests
Please clarify the functions and avoid misunderstanding 


LibO: 
Version 3.6.6.2 (Build ID: f969faf)
and 
Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)

XP Pro / SP3
Comment 7 bugquestcontri 2013-04-26 04:30:06 UTC
Created attachment 78495 [details]
updated screenshots

previous screen shots can be deleted.
Comment 8 QA Administrators 2015-03-04 02:23:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 9 Jean-Baptiste Faure 2015-03-15 20:57:54 UTC
In current stable versions (4.3 and 4.4) Insert > Hyperlink already has a shortcut, it is ctrl+K and it is defined at the application level, not only for Writer. If you hit ctrl+K on an existing hyperlink, it is edited.

Best regards. JBF
Comment 10 tommy27 2016-04-16 07:25:34 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 11 Jean-Baptiste Faure 2016-04-30 16:59:35 UTC
For me it works as expected in LO 5.1.x and master.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF