Bug Hunting Session
Bug 60747 - UI: Customize Keyboard shortcut: Functions Edit Hyperlink and Insert Hyperlink switched
Summary: UI: Customize Keyboard shortcut: Functions Edit Hyperlink and Insert Hyperlin...
Status: RESOLVED DUPLICATE of bug 50063
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 21:30 UTC by Claude Andrew
Modified: 2013-02-27 17:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claude Andrew 2013-02-12 21:30:57 UTC
Define keyboard shortcut for insert hyperlink and when you press your key you'll get edit hyperlink; define for edit and you'll get insert.

Steps to reproduce:
1. Tools | Customise... | Keyboard (tab) | select unused shortcut key. Try Ctrl+K.
2. in "Category" list select "Insert"; in Function select "Hyperlink"
3. Click "Modify"
4. Click OK
5. In a document, type "Foo link bar". select "link" and press shortcut key (Ctrl+K in my example).

Current behavior:
Nothing happpens.

Expected behavior:
Insert Hyperlink dialog.

More steps:
Now create a shortcut for Edit Hyperlink:
6. Tools | Customise... | Keyboard (tab) | select unused shortcut key. Try Ctrl+SHIFT+K this time.
7. in "Category" list select "Edit"; in Function select "Hyperlink"
8. Click "Modify"
9. Click OK
10. In a document, type "Foo link bar". select "link" and press shortcut key (Ctrl+SHIFT+K in my example).

Current behavior:
Insert Hyperlink Dialog appears.

Expected behavior:
Nothing (there is no hyperlink to edit).

11. Type a few words and create hyperlinks for them with your EDIT HYPERLINK shortcut; edit existing hyperlinks with your INSERT shortcut.

Current behavior:
The EDIT shortcut in fact calls the INSERT function and the INSERT shortcut in fact calls the EDIT function.
Expected behavior:
EDIT function causes EDIT behavior, INSERT causes INSERT.


Operating System: Ubuntu
Version: 4.0.0.3 release
Comment 1 Brenda Granados 2013-02-27 17:29:08 UTC
Hi. I followed your steps to reproduce this on LibreOffice Version 4.0.1.0+. I found that you are right- when you customize a keyboard shortcut, your Insert Hyperlink does nothing initially.

However, I found a very similar bug that says you can work around that by choosing Insert in Category, and the function is "Insert Hyperlink". I will mark this bug as a duplicate of the other one. The other bug also specifies that Insert Hyperlink and Edit Hyperlink are switched.

*** This bug has been marked as a duplicate of bug 50063 ***