Download it now!
Bug 50286 - FILESAVE Saving to .doc decouples endnote number from text
Summary: FILESAVE Saving to .doc decouples endnote number from text
Status: RESOLVED DUPLICATE of bug 108448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2012-05-23 11:08 UTC by Johnny Gill
Modified: 2017-09-06 23:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johnny Gill 2012-05-23 11:08:06 UTC
1. What is expected to happen in Writer via the Terminal:
cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1002985/+attachment/3158838/+files/example.odt && lowriter --nologo example.odt

save the attached document in .doc format (97/2000/XP/2003), close, reopen and the endnote looks the same as it did in .odt.

2. What happens instead is the the endnote number is decoupled from the endnote text.
Comment 1 retired 2014-08-16 10:37:48 UTC
Still happening LO 4.3.1RC1 OSX 10.9.4

OS -> ALL

Endnote is decoupled indeed.
Comment 2 QA Administrators 2015-09-04 02:49:02 UTC Comment hidden (obsolete)
Comment 3 Johnny Gill 2015-09-08 02:42:19 UTC
I just tested this with:

Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_CA

On Ubuntu 15.04.

Saved as docx and it opened fine in Libre Office.

Would be good to test whether it works in Word, but I don't have that :)

Guessing this one is fixed.  

Footnotes looked pretty good too :)
Comment 4 Iwan Lamble 2016-09-06 10:02:45 UTC
I've tested saving the file as .doc and .docx and it opens fine in Libre Office, but not in Word 2010.

In Word there is still a big gap between the endnote number and the text.

Also, the character for the endnote changes from a '1' to roman numeral 'i' when opening .doc in Word (this doesn't happen for .docx)
Comment 5 Iwan Lamble 2016-09-06 10:08:50 UTC
Endnote character changing is bug 40101
https://bugs.documentfoundation.org/show_bug.cgi?id=40101
Comment 6 Justin L 2017-09-06 23:41:23 UTC
A carriage return was added each time the document was saved and re-opened. That was fixed in LO 6.0 for bug 108448.

Johnny Gill: this bug report is about .doc, not .docx right? So comment 3 doesn't really apply?

Iwan: It seemed that I needed to modify the document to notice the extra carriage return being added. A simple load and save didn't trigger it. So in my testing I always changed the page size before saving.

Comment 4: Yes, there is still a big gap (a tab) added to the footnote.  There are other bug reports relating to that, so not worrying about that in this report.

Comment 4: Yes, the endnote character shows up as i instead of 1 in MSWord. In LibreOffice, that is defined in Tools - Footnotes and Endnotes. The default is roman numberals for endnotes. See bug 40101 and bug 40049.

Interestingly, MSWord2013 cannot see the first page (with "Affects the World") but only the endnote page.  This is true all the way back to LO 3.6. However, Word 2003 opens it up fine, so we won't worry about MSWord's bug.

Closing because the "decoupled" problem has been resolved in LO 6.0.

*** This bug has been marked as a duplicate of bug 108448 ***