Download it now!
Bug 50379 - FORMATTING: page-anchored drawing objects get lost.
Summary: FORMATTING: page-anchored drawing objects get lost.
Status: RESOLVED DUPLICATE of bug 89477
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 54292 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Object-Selection-Alignment
  Show dependency treegraph
 
Reported: 2012-05-26 15:26 UTC by bram.wayman
Modified: 2020-03-04 07:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (9.88 KB, application/vnd.oasis.opendocument.text)
2012-05-26 22:47 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bram.wayman 2012-05-26 15:26:13 UTC
When a drawing object is anchored to a page, and a paragraph style that specifies a page break is used earlier in the document, the drawing object's anchor does not move with its page. Example: Let's say I have an 8-page document, with a drawing object anchored to page 6, and I use a paragraph style that includes a preceding page break on page 3. The document is now 9 pages long, and the newly styled paragraph appears on page 4. But the drawing still appears on page 6, while it should appear on what is now page 7. It should have moved along with all the contents it shared that page with.
Comment 1 Rainer Bielefeld Retired 2012-05-26 22:47:21 UTC
Created attachment 62129 [details]
Sample document

[Reproducible] with "LibreOffice 3.5.4.2 (RC2) German UI/Locale [Build-ID: 165a79a-7059095-e13bb37-fef39a4-9503d18] on German WIN7 Home Premium (64bit)?

In attached sample document you have paragraph anchored drawings on pages 5,7, and a drawing anchored to page on page 6.

After inserting a page break on page 3 you will see Drawings "5" and "Page 6" both on page counted as 6. 

@reporter:
That is your problem?
Comment 2 bram.wayman 2012-05-28 15:28:31 UTC
Yes, that's the issue. It appears it's related to page breaks in general, not just to breaks specified in paragraph styles. Thanks for putting that sample together. It confirms what I see on my end.
Comment 3 Stanislav Horacek 2013-11-08 16:21:41 UTC
*** Bug 54292 has been marked as a duplicate of this bug. ***
Comment 4 QA Administrators 2015-04-19 03:20:50 UTC Comment hidden (obsolete)
Comment 5 Stanislav Horacek 2015-04-20 16:59:51 UTC
Still reproducible - tested in 4.4.2.1 (Ubuntu 14.10).
Comment 6 QA Administrators 2016-09-20 09:33:13 UTC Comment hidden (obsolete)
Comment 7 Stanislav Horacek 2016-09-21 19:16:54 UTC
Reproducible in 5.2.1 and current master (Kubuntu 16.04).
Comment 8 QA Administrators 2018-06-17 02:44:51 UTC Comment hidden (obsolete)
Comment 9 Samuel Mehrbrodt (CIB) 2020-03-04 07:38:24 UTC
I guess you

*** This bug has been marked as a duplicate of bug 89477 ***