Download it now!
Bug 50399 - FILESAVE document created with 3.4.5 destroys grouped elements for 3.4 VIEWING
Summary: FILESAVE document created with 3.4.5 destroys grouped elements for 3.4 VIEWING
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 50396 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-05-27 10:39 UTC by Rainer Bielefeld Retired
Modified: 2013-07-31 18:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
New Test Kit (228.98 KB, application/x-zip-compressed)
2013-01-19 07:58 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-27 10:39:59 UTC
Fond that during my investigations for "Bug 50396 - EDITING: grouped shapes drawings become distorted" Bug 50396 - EDITING: grouped shapes drawings become distorted and current Master-

Steps to reproduce:

1. download and unzip testkit attachment 62144 [details]
2. open "veryearly345.odg"  with 3.5.4
3. save under new name and close
4. open new document with 3.4.5
   Expected: Room window in second sheet looks like room window 
             (veryearly345.pdf)
   Actual: window destroyed as you see in veryearly354.pdf

Of course this might be a bug in 3.4.5, I believe I had some discussions concerning such a case not long ago, but I can't find the bug.

The very bad thing: if you edit the document and save with 3.4.5, the window will look broken when you open that document with 3.5.4
Comment 1 Hashem Masoud 2012-10-04 07:26:38 UTC
Is this bug relevant anymore? Release 3.4.5 is slightly old.
Comment 2 Rainer Bielefeld Retired 2012-11-28 18:53:02 UTC
Problem still is reproducible for me for interchange of that sample drawing "veryearly345.odg", saving it with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit) makes it unusable with AOOo 3.4.1..

I created "FineInLibO3641_badwithAOoo341.odg" by opening it with LibO 3.6.4.1 and saving it again. Now the doucment can be used with LLibO 3.6, but the window looks broken when I open the document with AOO 3.4.1 (but not when I open document with LibO 3.5.7.2.
Comment 3 ydutrieux 2012-12-15 18:31:34 UTC
I confirm this bug on Libo Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)

Reopening document with AOO3.4 there is the "windows" difference.

this is ok with lIBO 3.6.4.1
Comment 4 Rainer Bielefeld Retired 2013-01-19 07:58:59 UTC
Created attachment 73275 [details]
New Test Kit

Because of the slow progress I will try a new attempt with an individual test kit. It shows how every edit with a different version destroys a grouped draw element a little more
Comment 5 Rainer Bielefeld Retired 2013-01-19 08:22:27 UTC
NEW due to comment 3

I wonder whether the bug is in 3.4 or in 3.6? There is no interchange problem between 3.5.7 and 4.0.0.1, alternating open and save does not cause damages. But interoperability to AOOo is damaged.

@Thorsten:
We need an expert's decision whether the bug is in 3.4 or in 3.5 and later; can you help?
Comment 6 Thorsten Behrens (CIB) 2013-01-21 09:48:36 UTC
(In reply to comment #5)
> @Thorsten:
> We need an expert's decision whether the bug is in 3.4 or in 3.5 and later;
> can you help?
>
Bit hard to tell from testkit.zip - what is the original file and the history? FWIW, the diff between 
sampleok_odf12_savedfrom345.odg and sampleok_odf12_savedfrom345_savedfrom4001+.odg is a microscopic difference in shape y position:


- <draw:custom-shape draw:style-name="gr22" draw:text-style-name="P8" draw:layer="layout" svg:width="0.4cm" svg:height="0.421cm" svg:x="4.4cm" svg:y="5.517cm">
+ <draw:custom-shape draw:style-name="gr22" draw:text-style-name="P8" draw:layer="layout" svg:width="0.4cm" svg:height="0.421cm" svg:x="4.4cm" svg:y="5.515cm">

after that it indeed gets worse.
Comment 7 Rainer Bielefeld Retired 2013-01-21 10:05:50 UTC
(In reply to comment #6)
You can see it in the document names: the shortest name is the first source:
* sampleok_odf12_savedfrom345.odg

* sampleok_odf12_savedfrom345_savedfrom4001+ 
  source is opened and saved from 4.0.0.1+

* sampleok_odf12_savedfrom345_savedfrom4001_savedfrom345.odg
  sampleok_odf12_savedfrom345_savedfrom4001+.odg
  opened and saved from 3.4.5

* sampleok_odf12_savedfrom345_savedfrom4001_savedfrom345_Savedfrom4001+.odg
   sampleok_odf12_savedfrom345_savedfrom4001_savedfrom345.odg opened and saved
   from 4.0.0.1

and so on.

The end of the document name tells from what LibO version the document has been saved. the name before shows the open-save history before.
Comment 8 Rainer Bielefeld Retired 2013-02-12 21:19:12 UTC
*** Bug 50396 has been marked as a duplicate of this bug. ***
Comment 9 Joel Madero 2013-02-12 22:09:27 UTC
Moving this to 3.6 MAB.

Rainer - it's your opinion that this should stay on MAB list? How many people do you think are affected?
Comment 10 tommy27 2013-07-31 18:25:54 UTC
took the sampleok_odf12_savedfrom345.odg from you test kit.

I loaded it and saved and reloaded with 4.0.4 and 4.1.0 multiple times alternatively and I don't show the progressive "corruption" of the window image you reported with older LibO releases.

the only thing I notice is microscopic y axis position shift of the whole "house" image (already reported in Comment 6) and a font change in the text of the first page (from Arial to Times New Roman)

it seems to me that the 4.0.x and 4.1.x branches are now able to load and save .odg files created with the 3.4.5 release with minor flaws.

since the original bug report is about the "corruption" of the grouped shapes drawings (the "window" image) which is not present with currently supported LibO 4.0.x and 4.1.x branches, I change status to WORKSFORME