Bug Hunting Session
Bug 50541 - EDITING: Letters jiggle with invisible characters
Summary: EDITING: Letters jiggle with invisible characters
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA Confirmed:4.2.0.4:OSX
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2012-05-31 07:48 UTC by xavier.decuyper
Modified: 2015-05-02 15:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Video demonstrating the effect under OS X Lion (574.04 KB, video/quicktime)
2012-05-31 07:48 UTC, xavier.decuyper
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xavier.decuyper 2012-05-31 07:48:03 UTC
Created attachment 62337 [details]
Video demonstrating the effect under OS X Lion

Problem description: 

Steps to reproduce:
1. Enable invisible characters
2. Type some text
3. The letters will jiggle.

Here's a video to demonstrate the effect: https://dl.dropbox.com/u/15624590/LO_letter_jiggle.mov

Expected behavior: They shouldn't jiggle. It should be the same as when you disable the invisible characters.

Platform (if different from the browser): Mac OS X Lion, 10.7.4
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.52 Safari/536.5
Comment 1 ydutrieux 2012-12-17 08:06:14 UTC
NOT reproduced on libo 4 Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Ubuntu 12.04 64Bits
Comment 2 Jorendc 2012-12-27 18:47:44 UTC
I can reproduce using 3.6.4.3 and 4.1.0.0.alpha0+ (Build ID: 699132c269a6c6d9e815fc582e2e6a106e46923)
TinderBox: MacOSX-Intel@1-built_no-moz_on_10.6.8, Branch:master, Time: 2012-12-27_01:05:51

When you hit 'space' the previous word(s)/letters would jiggle.
Comment 3 retired 2014-02-05 09:01:30 UTC
Confirmed:4.2.0.4:OSX
Comment 4 Joel Madero 2015-05-02 15:44:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 5 steve -_- 2015-05-02 15:56:04 UTC
I can no longer reproduce this using Version: 5.0.0.0.alpha1+
Build ID: 393c51cee8bc3de5a2a9f4e04161c59e8712f631
TinderBox: MacOSX-10.10@61, Branch:master, Time: 2015-05-02_00:50:48
Locale: de-DE (de.UTF-8)

OSX 10.10.3

Since there is no specific commit fixing this issue, setting to WORKSFORME. FIXED is used only when a commit exists.

Feel free to reopen this issue if you still can reproduce this particular problem or if I did miss something peculiar.