Download it now!
Bug 50572 - EDITING: bug clipboard bug: after copying thousands of lines, and closing LO, process keeps running at 100% CPU
Summary: EDITING: bug clipboard bug: after copying thousands of lines, and closing LO,...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Cut-Copy
  Show dependency treegraph
 
Reported: 2012-06-01 01:25 UTC by andrey
Modified: 2019-04-08 02:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Test File for check this bug (2.72 MB, application/vnd.oasis.opendocument.spreadsheet)
2014-02-12 06:30 UTC, andrey
Details
This video shows the process of how it happens (1.57 MB, video/avi)
2015-08-06 13:10 UTC, andrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrey 2012-06-01 01:25:03 UTC
Problem description: 
bug with clipboard

Steps to reproduce:
1. Open document with 70000-80000 lines
2. Mark all (Ctrl+A)
3. Copy in clipboard(Ctrl+C)
4. Close document.

Current behavior:
LibreOffice closed, but he is running in processes and load 100% 1 core CPU 

Expected behavior:

Platform (if different from the browser): 
Windows XP(32 bit)
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Noel Grandin 2012-09-05 12:37:45 UTC
Tested in 3.6.1.2 (Windows)
Comment 2 andrey 2012-09-05 13:25:36 UTC
Problem has fixed not properly.

Steps to reproduce:
1. Open document with 70000-80000 lines
2. Add autofilter->Standart Filter->field>0
2. Mark all (Ctrl+A)
3. Copy in clipboard(Ctrl+C)
4. Close document.

Current behavior:
LibreOffice closed, but process(calc) is running and load 100% 1 core CPU and clipboard in windows does not work.

Tested in 3.6.1.2.
Comment 3 retired 2014-02-11 22:19:35 UTC
Andrey, please attach a test file.

Is this bug still valid / reproducible with the latest LO release?  Currently 4.2.0.4: http://www.libreoffice.org/download/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 4 andrey 2014-02-12 06:30:31 UTC
Created attachment 93901 [details]
Test File for check this bug

Bug is confirmed on LO 4.1.4.2
On version LO 4.2.0.4 I have not seen the dialog box for selecting of "Standard filter" to choose the value ">" 0(zero) in the field "balances"
But I waited 40 minutes!!!
And then i killed the process manually in task manager.
Resetting the profile did not help.
Comment 5 Joel Madero 2014-11-06 00:41:07 UTC
Version is oldest version not newest. Is this still an issue? 

If so - andrey, any thoughts?
Comment 6 andrey 2014-11-13 13:16:26 UTC
Version 4.3.3.2
Things got even worse. 
Now the application is not closed.
Comment 7 Cor Nouws 2014-11-13 13:41:14 UTC
@andrey: pls don't change the version to a newer one :) (Read the note that appears when you change that field :p )
Comment 8 raal 2015-06-25 06:37:15 UTC
Cannot reproduce with LO 4.4.3, win7
Comment 9 ribotb 2015-07-18 13:31:54 UTC
(In reply to andrey from comment #2)
> Problem has fixed not properly.
> 
> Steps to reproduce:
> 1. Open document with 70000-80000 lines
> 2. Add autofilter->Standart Filter->field>0
> 2. Mark all (Ctrl+A)
> 3. Copy in clipboard(Ctrl+C)
> 4. Close document.
> 
> Current behavior:
> LibreOffice closed, but process(calc) is running and load 100% 1 core CPU
> and clipboard in windows does not work.
> 
> Tested in 3.6.1.2.

Hi,

Not reproduce with LO 4.4.5.1 / LO 5.0.0.3 and file balances2.ods
Win7/x86, cpu 2,5 Ghz, ram 3 Go

Bernar
Comment 10 Buovjaga 2015-07-29 18:50:23 UTC
Andrey: please test with 4.4 and/or 5.0.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 11 andrey 2015-08-06 12:59:40 UTC
Just I checked on 5 version. The error remained.
Comment 12 andrey 2015-08-06 13:10:17 UTC
Created attachment 117713 [details]
This video shows the process of how it happens

This video shows the process of how it happens
Comment 13 Cor Nouws 2015-08-28 06:08:37 UTC
The bug tdf#93423 seems to give ground to this report :)
Comment 14 FutureProject 2016-01-11 02:40:05 UTC
> Problem has fixed not properly.
> 
> Steps to reproduce:
> 1. Open document with 70000-80000 lines
> 2. Add autofilter->Standart Filter->field>0
> 2. Mark all (Ctrl+A)
> 3. Copy in clipboard(Ctrl+C)
> 4. Close document.
> 
> Current behavior:
> LibreOffice closed, but process(calc) is running and load 100% 1 core CPU
> and clipboard in windows does not work.
> 
> Tested in 3.6.1.2.

Can confirm bug present in LibreOffice version 5.0.4.2 build id 2b9802c1994aa0b7dc6079e128979269cf95bc78 using Win10. After Ctrl+C and closing the LibreOffice window the task remains running at 100% on one core. Used the provided test file.
Comment 15 QA Administrators 2017-03-06 13:49:45 UTC Comment hidden (obsolete)
Comment 16 andrey 2017-03-07 06:34:15 UTC
The bug is present in LO 5.3.0 x86 version on Windows 7 x86 with all updates.
Comment 17 Xisco Faulí 2017-07-13 10:57:52 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 18 QA Administrators 2019-04-08 02:46:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug