Download it now!
Bug 50911 - FILEOPEN impossible for any existing.ods
Summary: FILEOPEN impossible for any existing.ods
Status: RESOLVED DUPLICATE of bug 50587
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 50910 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-06-09 04:24 UTC by Rainer Bielefeld Retired
Modified: 2012-07-09 06:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-06-09 04:24:36 UTC
I see that with Server Installation of "LibreOffice 3.6. 0beta1  English UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit) using my default User Profile from 3.5.4

Open new spreadsheet (from Start Center) works fine, but none of the existing documents I tried can be opened. Message: "Read Error. An unknown error has occurred."

I believe this is the root problem of "Bug 50910 - Impossible to access particular spreadsheet based database table"
Comment 1 Rainer Bielefeld Retired 2012-06-09 05:50:17 UTC
Not reproducible after a PC reboot. I will do some further tests, but might have been a onetime effect.
Comment 2 Jean-Baptiste Faure 2012-06-09 05:54:07 UTC
Not reproducible for me with LO 3.6.0alpha1+ (Build ID: 214c3b9) under Ubuntu
11.10 x86_64 with gnome-shell.

Best regards. JBF
Comment 3 Rainer Bielefeld Retired 2012-06-09 09:08:09 UTC
*** Bug 50910 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2012-06-09 09:09:51 UTC
Not reproducible with a second installation on an other WIN7 PC, so this one seems to be bad luck and not a LibO Bug. WFM for now
Comment 5 Winfried Donkers 2012-06-12 01:16:15 UTC
LO 3.6.0beta1, Windows XP: reproducible after installing, no longer reproducible after reboot.
Comment 6 Winfried Donkers 2012-06-12 01:18:34 UTC
see previous comment (forgot to reopen bug).
IMHO this behaviour should be corrected, or at least (but not preferably) user should be informd that rebooting is necessary.
Comment 7 Michael Meeks 2012-06-14 08:08:56 UTC
Andras - Windows specific bug post install, and up-to reboot (!?) - any thoughts ? :-)
Comment 8 Andras Timar 2012-06-14 09:37:20 UTC
I can't reproduce it.
Comment 9 Rainer Bielefeld Retired 2012-06-14 11:03:43 UTC
Saw problem again, this time after a CALC crash with "Server Installation of LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit) using my
copied User Profile from 3.5.5.1

It happened after a CALC crash, now this LibO lost ability to open existing CALC documents. Reboot and deletion of User Profile did not help, I will have to pulp this installation. 

I believe this should be reproducible for you with a zipped Server installation, what might lead to an idea what caused the problem? I will prepare a download from my server, I > 200MB 7z might be too much for an e-mail.
Comment 10 Rainer Bielefeld Retired 2012-06-15 00:20:16 UTC
You can download my Server Installation from <http://www.bielefeldundbuss.de/LibO/50911/20120614beta1.7z>  (170MB)

With a little luck you will be able to reproduce my Problem on a WIN system, it should be able for use simply after having been unpacked.

The User Profile (is within the installation) has been created natively by this installation.

The problem might be related to "Bug 51100 - EDITING copy / paste cells in particular .ods will CRASH"
Comment 11 Winfried Donkers 2012-06-25 01:17:40 UTC
problem also/still occurs with 3.6.0.0beta2 on Windows XP. 
(install lodev3.6, start lodev3.6, open ods file : "read error. An unknown error has occurred.")
Comment 12 Kohei Yoshida 2012-07-06 19:06:16 UTC
I'm 99% sure this has been fixed via Bug 50587 in Beta 3.  If not, please re-open once again.

*** This bug has been marked as a duplicate of bug 50587 ***
Comment 13 Winfried Donkers 2012-07-09 06:59:55 UTC
(In reply to comment #12)
> I'm 99% sure this has been fixed via Bug 50587 in Beta 3.  If not, please
> re-open once again.
> 
> *** This bug has been marked as a duplicate of bug 50587 ***

Problem no longer occurs with beta3 on Windows XP. Thanks!