Bug 50967 - File >> Wizards >> Address Data Source Yields No UI
Summary: File >> Wizards >> Address Data Source Yields No UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Linux (All)
: high normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta3
Keywords: regression
Depends on:
Blocks: Address-Source
  Show dependency treegraph
 
Reported: 2012-06-11 07:28 UTC by Dave Richards
Modified: 2017-12-06 20:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2012-06-11 07:28:56 UTC
In testing 3.6 alpha on 64bit, File >> Wizards >> Address Data Source does not bring up the expected UI.  Retested on 3.5 where it works fine.  Testing from the command line and no errors are reported; it just never opens.

Looks like my build was created on June 4th, last available that I can find.
Comment 1 Dave Richards 2012-06-12 06:04:10 UTC
Broken in Beta too.
Comment 2 Michael Meeks 2012-06-25 09:55:57 UTC
possible duplicate of bug#51115 - worth trying a daily build of master tomorrow perhaps (?)
Comment 3 Michael Stahl (allotropia) 2012-06-25 09:59:00 UTC
doesn't look like it has anything to do with bug 51115, which
only affects Impress/Draw extensions on Windows.
Comment 4 Michael Stahl (allotropia) 2012-06-26 04:25:15 UTC
works for me on all my self-built 3-6 Linux branch builds;
Caolan, do you have any idea what the usual reason is
why this address book stuff would break?
Comment 5 Caolán McNamara 2012-06-26 05:14:35 UTC
with catch throw and break dlopen on the release build it appears that the offender is libkab1lo.so, i.e. the KDE address book support
Comment 6 Caolán McNamara 2012-06-26 05:29:29 UTC
built against kde3 which don't have, so driver is "available" but can't be loaded. I can simulate it in a debugging version by e.g. deleting one of the other providers
Comment 7 Not Assigned 2012-06-26 05:38:44 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=037ddf9c77b5cd50ab41d656222f4d43597b22cc

Resolves: fdo#50967 Address DataSource dialog fails on throws
Comment 8 Not Assigned 2012-06-26 05:45:33 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a8687f47793afbf4b6a837e769ef2de31c3f0b36&g=libreoffice-3-6

Resolves: fdo#50967 Address DataSource dialog fails on throws


It will be available in LibreOffice 3.6.