Bug 51036 - EDITING: Prompts to install Java when cutting and pasting on computer without Java installed
Summary: EDITING: Prompts to install Java when cutting and pasting on computer without...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE-Warnings Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2012-06-13 06:51 UTC by William Lachance
Modified: 2016-11-11 21:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description William Lachance 2012-06-13 06:51:38 UTC
I recently installed LibreOffice 3.5 on my wife's new macbook air running Lion, which does not have Java installed by default. Whenever she would cut and paste, she would be prompted to install Java, for some reason I don't quite understand. In any case, unchecking "Use a java runtime environment" from options seems to have fixed the issue.

I understand there are some parts of LibreOffice which use Java. I guess it's ok to prompt if they're being activated. I don't think that's the case here though. 

The behaviour I would expect is that a user who is just using the basics of writer should never be asked to install software which is not necessary to the task at hand (cutting and pasting). Not sure the best way of accomplishing that -- maybe making "use a java runtime" option false if no java runtime is installed?
Comment 1 Roman Eisele 2012-08-18 16:37:13 UTC
Thank you very much for your bug report!

I completely agree with you that the behaviour of LibreOffice you describe is annyoing and needs to be fixed (Java installation and activation should not be necessary for a simple thing like cut/copy/paste).


This issue is more or less REPRODUCIBLE with
* LibreOffice 3.5.6.2 (Build ID: e0fbe70-dcba98b-297ab39-994e618-0f858f0) and
* LibreOffice 3.6.1.1 (Build ID: 4db6344),
both on MacOS X 10.6.8 (Intel), with German langpack installed.

My steps:
1) disable the Java VM completely (on MacOS X 10.6.x, this is done via
   starting Applications/Utilities/Java Setup.app,
   selecting tab "General",
   and unchecking all checkboxes);
2) start LibreOffice;
3) open any Writer document;
4) select some character(s) or words;
5) select "Edit > Copy" or "Edit > Cut" from the menu,
   or press Command+C or Command+X;
-> the alert box visible in attachment 65728 [details] appears.

Two observations:

(i) Interesting enough, this happens only once; i.e., after the 1st time the alert box appears, I can copy/paste several times without the box reappearing. Only when I quit LibreOffie and restart it, the next time I try to cut/copy any text, the alert appears again. This is a little difference to the original description (comment #0) which says "_Whenever_ she would cut and paste [...]".

(ii) Unchecking "Use a java runtime environment" in the LibreOffice application preferences (section "LibreOffice" > "Java") does not really fix the issue for me, it just changes the behaviour: on my first attempt to cut/copy any text after starting LibreOffice, another alert box appears (visible in attachment 65729 [details]) which allows to choose between "Yes", "No", and "Cancel"; if I press "No", I can continue working (incl. cut and copy of text) without any alert, until I restart LibreOffice.


@William Lachance:

To make sure that we see exactly the same issue, could you please check (if possible) if you can confirm my two little observations above (i.e. (i): the alert appears only on the first attempt to copy/paste text after starting LibreOffice; (ii) unchecking "Use a java runtime environment" in the application preferences does not fix the issue completely, it just changes the kind of alert which appears), or if you really see the alert box every time you try to cut/copy any text.

Just describe your results in an additional comment on this page (https://bugs.freedesktop.org/show_bug.cgi?id=51036, click "Add Comment").

Thank you very much in advance!
Comment 2 Roman Eisele 2012-08-28 13:01:52 UTC
Because we did not get an answer in my question in comment #1 yet, I set the status of this bug to NEW anyway (because it *is* reproducible, see comment #1), to prevent that it gets closed because of the missing answer.

@William Lachance:
It would be still be helpful if you could try to get back to us and answer my question in comment #1. Thank you very much!
Comment 3 QA Administrators 2015-01-05 17:51:40 UTC Comment hidden (obsolete)
Comment 4 Alex Thurgood 2015-03-25 13:48:54 UTC
There appears to be no way to test this behaviour on OSX 10.10 other than by removing Java from the file system, as the option to switch off Java via the Utilities > Java setup dialog was removed when Apple abandoned its own version of Java for the one provided by Oracle.

Note that the problem originally manifested itself on OSX 10.6 and 10.7 for which LO 4.3.x versions are the last that will supported for these OSes. As LO 4.4 is 64bit only, the test parameters of the original bug report can not be met.

Additionally, my understanding is that LO now requires both Apple Java for OSX and Oracle Java > 1.7 to be present, see bug 74877, and bug 89695, so testing this without a JDK/JVM even just by opening a Writer document is guaranteed to provoke a "missing Java" error
Comment 5 Alex Thurgood 2015-03-25 13:49:53 UTC
I would be inclined to set this as wontfix in line with bug 74877
Comment 6 tommy27 2016-04-16 07:23:48 UTC Comment hidden (obsolete)
Comment 7 eisa01 2016-11-11 21:58:12 UTC
Just uninstalled Java and this works for me

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 2; OS Version: Mac OS X 10.12; UI Render: default; 
Locale: en-US (en_NO.UTF-8); Calc: group