Bug 51047 - [GTK+ 2] White box around buttons in toolbars and About Dialog
Summary: [GTK+ 2] White box around buttons in toolbars and About Dialog
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.0.alpha1
Hardware: Other Linux (All)
: low normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 63348 (view as bug list)
Depends on:
Blocks: About-Dialog
  Show dependency treegraph
 
Reported: 2012-06-13 12:41 UTC by Tomasz Sałaciński
Modified: 2020-04-14 06:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of about dialog (106.67 KB, image/png)
2012-06-13 12:41 UTC, Tomasz Sałaciński
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Sałaciński 2012-06-13 12:41:47 UTC
Created attachment 62984 [details]
Screenshot of about dialog

Problem description: 
See screenshot; there's a white box surrounding every button in the about dialog. Because of darker background, it's best visible around the "Close" button

Steps to reproduce:
1. Open about dialog
2. Look at the buttons
3. ....

Current behavior:
White box surrounding buttons

Expected behavior:
There should be no white box

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0
Comment 1 Rainer Bielefeld Retired 2012-06-13 13:01:23 UTC
NOT reproducible with Server Installation of  "LibreOffice 3.6.0beta1  English UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit).

Linux, graphic card, something else?
Comment 2 Tomasz Sałaciński 2012-06-13 13:12:25 UTC
It's Linux, Ubuntu 12.04 with GNOME Shell with NVIDIA graphic card.
Comment 3 Andras Timar 2012-06-13 13:48:09 UTC
Confirmed on Linux.
Comment 4 Adolfo Jayme 2013-05-06 02:52:18 UTC
*** Bug 63348 has been marked as a duplicate of this bug. ***
Comment 5 retired 2014-01-17 10:55:01 UTC
Is this bug still valid / reproducible with the latest pre-release 4.2.0.2: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to NEW. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 6 QA Administrators 2014-08-04 16:17:26 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2014-09-03 12:05:13 UTC Comment hidden (obsolete)
Comment 8 Adolfo Jayme 2014-09-05 04:23:00 UTC
Rescuing this bug. Of course it still happens.
Comment 9 Adolfo Jayme 2015-03-24 06:40:19 UTC
FWIW, this problem is gone in the GTK+ 3 port, which even renders semi-transparent buttons nicely (give the elementary theme a try, for example). I’m not sure if it’s feasible to fix this in the default GTK+ 2-based UI.
Comment 10 tommy27 2016-04-16 07:27:42 UTC Comment hidden (obsolete)
Comment 11 Jean-Baptiste Faure 2016-07-09 15:40:49 UTC
Still reproducible in LO 5.1.4 (Ubuntu build) and 5.2.1.0.0+ (home build) with GTK 2 plugin.
I see the same withe box surrounding each button of the start-center.

Best regards. JBF
Comment 12 QA Administrators 2017-10-23 14:08:52 UTC Comment hidden (obsolete)
Comment 13 Jean-Baptiste Faure 2017-10-28 16:31:15 UTC
Still reproducible with LO 5.4.4.0.0+ built at home under Ubuntu 16.04.

Best regards. JBF
Comment 14 QA Administrators 2018-10-29 03:57:24 UTC Comment hidden (obsolete)
Comment 15 Jean-Baptiste Faure 2018-10-29 08:06:22 UTC
Still reproducible in current master built at home under Ubuntu 18.04 x86-64:
Version: 6.2.0.0.alpha1+
Build ID: 951a65923c088a1e19a4073f3c26a3b564a0a922
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: gtk2; 
Ubuntu_18.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

The problem is not visible on the About dialog but is clearly visible in the Start Center.

Shouldn't this bug closed as WontFix as it concerns only GTK2?

Best regards. JBF
Comment 16 QA Administrators 2019-10-30 03:36:22 UTC Comment hidden (obsolete)
Comment 17 Jean-Baptiste Faure 2019-11-17 11:03:41 UTC
About dialog has been rewritten since LO 6.3, and this bug does not appear in this and the subsequent versions.

Closing as WorksForMe because I am not able to find the right commit.

Best regards. JBF
Comment 18 Jean-Baptiste Faure 2019-11-17 11:09:23 UTC
Even with GTK2 backend, I do not see the bug in LO 6.3.4.0+.

Best regards. JBF
Comment 19 Masan Lyrics 2020-04-14 06:11:59 UTC Comment hidden (spam)