Bug 51178 - FILEOPEN document from older version: cell borders width looks thicher than when opened with old version
Summary: FILEOPEN document from older version: cell borders width looks thicher than w...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 52203 52431 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-17 13:06 UTC by Rainer Bielefeld Retired
Modified: 2013-03-07 17:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample document (67.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-06-17 13:06 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-06-17 13:06:20 UTC
Created attachment 63146 [details]
sample document

Steps how to reproduce with "LibreOffice 3.5.5.1  German UI/Locale [Build-ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8] on German WIN7 Home Premium (64bit):
Open attached sample document with 3.5.5.1 and a copy with 3.4.5, compare blue border thickness for column A (copied from an old document created with 3.5.4(?): look thin with 3.4.5, much thicker with 3.5.5.1.

I also opened Document with 3.5.3 RC1, there border width looks ok.
Comment 1 s-joyemusequna 2012-06-18 04:08:46 UTC
Confirmed. Thin with 3.4.5, thick with 3.6 Beta1 and LOdev 3.7 (Win-x86@6-fast, 2012-06-14). Tested with Windows XP and Vista 64.
Comment 2 Markus Mohrhard 2012-06-19 02:36:45 UTC
This is not a bug in 3.5.5 and 3.6.0+. It is a fixed bug in them. Before the fixed bug we did not calculate the size of the border correctly, all border between 0.05pt and 1pt looked exactly the same than we had one step till 2.0pt and so one while we allowed to have a precision of 0.01pts.
Comment 3 Rainer Bielefeld Retired 2012-07-17 15:52:04 UTC
*** Bug 52203 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2012-07-24 09:18:01 UTC
*** Bug 52431 has been marked as a duplicate of this bug. ***
Comment 5 S.Andreason 2012-11-19 20:11:25 UTC
I have an older sheet with double-line borders to mark special cells. Now they look like one thick line at 100% zoom. I can see the double line, but only if I zoom in ridiculously far.
I disagree the point size is being calculated correctly, for if the original border was 0.25 pt, it should still show up as a single 1 point line at most. 3 points total for a double-line border.
If fact if you take a screenshot, and zoom in on that double-line border, each line looks more like it has been anti-alias blurred into 3 pixels for each line, totaling 6 pixels tall.

It is this blurring I believe is a bug.
Comment 6 S.Andreason 2012-11-19 20:20:02 UTC
How about duplicating this:
Add border, 0.05pt double line (2nd from the bottom in the new listbox)
at 100% this line is 4 pixels tall, a solid line. 
Not seeing the blur I just reported, so must be a different cause?

If I zoom in to max, it is still a solid line. 

The double-line option has been lost. Requesting regression or something.
Comment 7 Rainer Bielefeld Retired 2012-11-19 21:16:30 UTC
@S.Andreason:
There is a difference between "Borders in my document do not look as I expect" and "Borders in document do not look as I expect" 

To be honest, I don't understand at all what want to tell here. If you find out that Markus Mohrhard's comment concerning effects with my sample document is wrong and if you can cite evidence why it is wrong co can reopen ths Bug.

For anything else please submit a separate report with a clear description due to  <http://wiki.documentfoundation.org/BugReport>
Comment 8 terencecguard-bugreport 2012-11-20 09:17:41 UTC
So basically something was fixed in 3.5.5. and 3.6.0+ which had no previous end user impact?  After the fix it now has a user impact. But we are stuck with it.
Comment 9 S.Andreason 2012-11-20 21:55:45 UTC
Rainer,
Your sample document is not touching my issue. Your borders are all single line.

I am following the directions to find an existing bug and not create duplicates.
Your bug is titled "width looks thicker" etc. that does match my complaint.

If you don't like my attaching onto your bug, then I will go file a new bug, 57345, so that somebody else can say it is a duplicate of 51178.

Terence,
You could say it that way, yes.
The fix does have unintended consequences, as is the usual case in all programming. It creates a new "end user impact" that was not predicted. The double-line border (1 pixel solid-1 pixel transparent-1 pixel solid) has effectively been lost. I can not find a setting to get it back.

I will make a test .ods and .png of the problem I am seeing.

Stewart
Comment 10 Rainer Bielefeld Retired 2012-11-21 05:09:52 UTC
@S.Andreason 
So please let us check your problem in a separate bug and see whether it is related to Markus' comment or something different what might get a fix.