Bug Hunting Session
Bug 51401 - Better shortcut category for forward and back navigation functions
Summary: Better shortcut category for forward and back navigation functions
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: x86 (IA32) All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2012-06-25 02:30 UTC by narayanaras
Modified: 2018-05-05 21:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2012-06-25 02:30:58 UTC
1. Right-click on any toolbar and select "Customize toolbar..." option.
2. The "Customize" window pops up. Select the "keyboard" tab.
3. In the bottom section, select "Navigate" category.
4. Look for the "Forward" and "Back" functions. They are missing.

As a result, you cannot assign a keyboard shortcut (hotkey) to these functions.

This is a major productivity loss: When you CTRL+click on a link (e.g. from TOC to a heading, or from a hyperlink to a bookmark), you cannot quickly come back by pressing a hotkey (say, ALT+LeftArrow, as in a pdf reader). 

You have to click on the "green arrow" button in the Navigate" toolbar.


Solution: Provide the "Forward" and "Back" functions in the "Navigate" category.
Comment 1 Robert Großkopf 2013-08-25 15:51:40 UTC
I have just looked for unconfimed bugs. So I found this.
I searched through the categories. I couldn't find "Forward" and "Back" in the "Naviagte"-category. Then had a look in the other categories - "Back" must be at the top, so I only clicked through them.
I found "Back" and "Forward" in the Category "Internal". Why it is there I couldn't say. But you can chose a shortcut key for it.

I will close this bug as "Resolved" and "Worksforme". If you would say it isn't the right category - I couldn't say, what developers had thought by this category. But then it is better to write a new bug-description for the category.
Comment 2 narayanaras 2014-04-07 07:29:43 UTC
Since there is a "Navigate" category, the logical place to look for the  "Forward" and "Back" functions is purely in this category. 

If they are provided in the different category, that's wrong design. 

A category name like "Internal" is meaningless, so people would not look there at all. (How can any application have an "internal" controls???)
Comment 3 Joel Madero 2014-11-06 00:13:22 UTC
Never confirmed by QA team - moving to UNCONFIRMED to get confirmation.
Comment 4 Buovjaga 2014-11-16 14:41:27 UTC
Well, let's change the title and set as a NEW enhancement.
Comment 5 V Stuart Foote 2018-05-05 02:53:15 UTC
This navigation is what the controls on the Navigation toolbar (Writer only, but applicable to other modules) are intended to provide, see bug 32869 and bug 115817

Not clear they can be made generic--or must be bound to a specific toolbar, dialog.
Comment 6 Maxim Monastirsky 2018-05-05 21:08:55 UTC
In the meantime it was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=66e8f52d10eb6ff779d177e61899e83f6a3b5a60