Bug 51453 - EDITING: ReportBuilder - group with restarting pagecount impossible
Summary: EDITING: ReportBuilder - group with restarting pagecount impossible
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
: 52485 (view as bug list)
Depends on:
Blocks: Database-Reports-Builder Database-Reports-Builder-MAB
  Show dependency treegraph
Reported: 2012-06-26 08:58 UTC by Robert Großkopf
Modified: 2023-04-18 15:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Open the reports area_pagecount... Page isn't set to 1 at new area (128.77 KB, application/vnd.sun.xml.base)
2012-06-26 08:58 UTC, Robert Großkopf
Shows, where you can find the function "reset page number" and what is the printout (96.42 KB, application/x-download)
2012-07-31 18:08 UTC, Robert Großkopf

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2012-06-26 08:58:54 UTC
Created attachment 63492 [details]
Open the reports area_pagecount... Page isn't set to 1 at new area

In the report-builder you could choose, that the counting of the pages should start again for every group. When you choose this nothing happens. Pagecount is the same as before.
When you choose this in a subgroup, the pagecount is the same as before - but there are pagebreaks in the report. Same behaviour as in bug 51452 with repeating of an area.
Comment 1 Robert Großkopf 2012-07-28 17:33:10 UTC
*** Bug 52485 has been marked as a duplicate of this bug. ***
Comment 2 Robert Großkopf 2012-07-31 18:08:44 UTC
Created attachment 65010 [details]
Shows, where you can find the function "reset page number" and what is the printout
Comment 3 Rainer Bielefeld Retired 2012-08-06 07:57:29 UTC
Not confirmed, no version info, may be that never worked better. Might be ugly, but currently I see nothing critical.

I will check this one later
Comment 4 Robert Großkopf 2012-08-06 10:37:03 UTC
You are right. That isn't critical. It wasn't my choose to set this.

This problem is a problem in LO 3.3 and all other versions - so I havent choosen any version.
Comment 5 Robert Großkopf 2013-08-07 14:45:31 UTC
Just testing all bugs from Report-Builder. This bug first appears in the oldest available version of LO, 3.3.0 beta1. So I set the first available bugzilla-version, 3.3.0 release.
Comment 6 Alex Thurgood 2015-01-03 17:39:22 UTC Comment hidden (no-value)
Comment 7 QA Administrators 2016-01-17 20:04:41 UTC Comment hidden (obsolete)
Comment 8 Robert Großkopf 2016-01-30 20:19:42 UTC
Bug still exists with LO, OpenSUSE 42.1 Leap, 64bit rpm Linux.
Comment 9 Robert Großkopf 2016-03-06 08:26:40 UTC
Bug appears in the first available LO-version (LO, OpenSUSE 42.1 64bit rpm Linux). So I set this bug as "Inherited From OOo".
Comment 10 QA Administrators 2017-03-06 15:50:28 UTC Comment hidden (obsolete)
Comment 11 Robert Großkopf 2017-03-08 17:57:05 UTC
Bug still exists with LO, OpenSUSE 42.1 Leap, 64bit rpm Linux.
Comment 12 QA Administrators 2018-03-09 03:46:27 UTC Comment hidden (obsolete)
Comment 13 Robert Großkopf 2018-03-09 07:28:21 UTC
Bug still exists with LO, OpenSUSE 42.3 Leap, 64bit rpm Linux.
Comment 14 QA Administrators 2019-03-10 03:21:43 UTC Comment hidden (obsolete)
Comment 15 Robert Großkopf 2019-03-10 07:52:06 UTC
Bug still exists on LO, OpenSUSE 15, 64bit rpm Linux

Don't know why, but the second attachment isn't downloadable any more.

You could find the function "reset page number" in the properties of every group header. Open the navigator of Report-Builder an click on the first group.
Comment 16 QA Administrators 2021-03-10 04:04:21 UTC Comment hidden (obsolete)
Comment 17 Robert Großkopf 2021-03-10 10:39:33 UTC
Bug still exists with LO, OpenSUSE 15.2, 64bit rpm Linux.
Comment 18 Alex Thurgood 2021-03-10 13:03:18 UTC
This is typically one of those Base reports that shouldn't be the subject of the incessant "bug me to confirm that the bug is still present in the current version" reminders.

Let's face it, if someone actually did some work on the ReportBuilder code, or rather, the way the reportbuilder UI seemingly provided for  a feature that clearly was either never implemented, or simply didn't work, this corrective work would probably be noticed almost immediately.

The bug was first reported in 2012...nearly 9 years ago. 
The fact that nothing has changed in that time with regard to this bug, and its sister bug 51452 is pretty indicative of the lack of any code development in this area. So why are we still pestering people like Robert to confirm something which almost with 100% certainty will not have changed since then ?

Of course, if Robert doesn't mind the reminders, then who am I to grumble ?
Comment 19 Robert Großkopf 2022-12-11 11:14:57 UTC
Have created a workaround for this bug.
Set the group to
Force New Page → Before Section.
Name the Group like "NewPage".
After the report has been executed you have to start

SUB GroupNewPage
	oReport = ThisComponent
	oTables = oReport.getTextTables()
	FOR inT = 0 TO oTables.count() - 1
		oTable = oTables.getByIndex(inT)
		IF Left$(oTable.name, 7) = "NewPage" THEN
			oTable.PageNumberOffset = 1

So we haven't to wait until this bug will be solved …