Bug Hunting Session
Bug 51535 - Start Center background does not change according to application background setting
Summary: Start Center background does not change according to application background s...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Robert Roth
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-28 13:57 UTC by Stefan Knorr (astron)
Modified: 2013-03-18 07:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-06-28 13:57:46 UTC
The Start Center uses a predefined background colour while the different parts of LibreOffice use a colour that can be defined under Tools > Options, Appearance, Application background.
This can lead to the Start Center having a different background colour than for instance a Writer document.
Ideally, the Start Center should pick up the Application Background colour, too.
Comment 1 Rainer Bielefeld Retired 2012-06-28 14:05:11 UTC
I can reproduce the described effect, also with more early versions. No Idea whethe it's a bug, but it seems inconsistent.
Comment 2 m.a.riosv 2013-01-06 13:55:21 UTC
*** Bug 59042 has been marked as a duplicate of this bug. ***
Comment 3 ape 2013-01-07 04:04:49 UTC
(In reply to comment #0)
> The Start Center uses a predefined background colour while the different
> parts of LibreOffice use a colour that can be defined under Tools > Options,
> Appearance, Application background.
> This can lead to the Start Center having a different background colour than
> for instance a Writer document.
> Ideally, the Start Center should pick up the Application Background colour,
> too.

Option 'Application background' does not work in  The Draw_LibO too. Color is very bright and is no different from the color of the page - see attachment 72527 [details]. Objects can extend beyond the page, and the user will not notice - rulers digitize the entire window. So I increased the severity.
Comment 4 Rainer Bielefeld Retired 2013-01-07 05:38:53 UTC
Already [Reproducible] with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit) and OOo 3.4.0

@ape
Your observation concerning LibO Draw is the same area, but a different bug, see my comments in Bug 59042.

<http://wiki.documentfoundation.org/BugReport_Details#Version>!
Comment 5 Caolán McNamara 2013-02-05 09:17:51 UTC
Robert Roth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=50685e3caf8d27d624a9006d578f686dfbe020c5

Start center background color uses application background color, fdo51535



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 ape 2013-03-18 07:36:04 UTC
(In reply to comment #5)
> Robert Roth committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=50685e3caf8d27d624a9006d578f686dfbe020c5
> 
> Affected users are encouraged to test the fix and report feedback.
--
Bugs are fixed.
Caolán! Include the patch in the LibreOffice-4.0.x please.