Download it now!
Bug 51614 - Conditional formating altered
Summary: Conditional formating altered
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: SURCOUF
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-01 04:04 UTC by SURCOUF
Modified: 2012-08-05 10:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File I've been working in (132.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-01 04:04 UTC, SURCOUF
Details
File illustrating the bug (1.37 MB, application/vnd.oasis.opendocument.graphics)
2012-07-01 04:09 UTC, SURCOUF
Details
File illustrating the bug (7.80 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-30 10:02 UTC, SURCOUF
Details
File illustrating the bug (7.69 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-30 12:31 UTC, SURCOUF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SURCOUF 2012-07-01 04:04:05 UTC
Created attachment 63661 [details]
File I've been working in

Hello,

I noticed another bug concerning CALC. After a research I found this:

Bug 45294 - FILEOPEN: Calc removed all the formulas inside my xlsx file

Yet, even if it seems to be likefull, the bug I have, concern ods extension files also. I was working with a file (see attachement), and I finally noticed that every of all my conditional formatings are gone. Even worse, the conditional formating popul window does not show any field to make a conditional formating. When the "ADD" button is pressed, a field appeard, but when pressed sevaral times, the former fields are affected (see attached file)

Sorry if ever this is a duplicate. Otherwise, hope that this will help.

Bunty

UBUNTU 12.04 LTS 64 Bits
GNOME 3.4.0
LibO 3.6.0 Beta 2 - Libreoffice 3.5.4.2
Comment 1 SURCOUF 2012-07-01 04:09:08 UTC
Created attachment 63662 [details]
File illustrating the bug
Comment 2 vitriol 2012-07-01 04:15:34 UTC
Duplicate of Bug 51555?
Comment 3 Jean-Baptiste Faure 2012-07-01 05:23:36 UTC
(In reply to comment #2)
> Duplicate of Bug 51555?

I guess it is a duplicate of bug 51507 which has been fixed yesterday. With the fix of this bug conditional formatting of type "formula is" are there.

@surcouf : it seems you can read French, so please have a look at this discussion on fr-discuss mailing list : http://nabble.documentfoundation.org/3-6-0-0-beta2-Formatage-conditionnel-dans-Calc-tp3992588.html

Please test again when beta3 will be out next week.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 51507 ***
Comment 4 SURCOUF 2012-07-01 05:44:46 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > Duplicate of Bug 51555?
> 
> I guess it is a duplicate of bug 51507 which has been fixed yesterday. With the
> fix of this bug conditional formatting of type "formula is" are there.
> 
> @surcouf : it seems you can read French, so please have a look at this
> discussion on fr-discuss mailing list :
> http://nabble.documentfoundation.org/3-6-0-0-beta2-Formatage-conditionnel-dans-Calc-tp3992588.html
> 
> Please test again when beta3 will be out next week.
> 
> Best regards. JBF
> 
> *** This bug has been marked as a duplicate of bug 51507 ***

Thanks for the deatils. I took a glance to the link you proposed. It's indeed the same bug. Sorry for the duplicate.

I'll wait for the beta 3 version to see.

Good day

Bunty

UBUNTU 12.04 LTS 64 Bits
GNOME 3.4.0
LibO 3.6.0 Beta 2 - Libreoffice 3.5.4.2
Comment 5 SURCOUF 2012-07-30 10:02:37 UTC
Created attachment 64947 [details]
File illustrating the bug

Hello,

Just installed the RC4 version. I noticed that none of my conditional formated cells give the expected result. I tried with a new file. I get the same result (see attached file). I even noticed a queer response concerning conditional formated cell; when a data is entered, it takes 3 to 4 seconds to validate the data (with another file).

May be someone will work over the issu.


Good day

Bunty

UBUNTU 12.04 LTS 64 Bits
GNOME 3.4.0
LibO 3.6.0 Beta 2 - Libreoffice 3.5.4.2
Comment 6 SURCOUF 2012-07-30 12:31:49 UTC
Created attachment 64952 [details]
File illustrating the bug

Hello,

JI tried other tests. I noticed that in a conditional formated cell done under LibO 3.5.5.3, the condition cell "SI(E12="OK")" is changed to "SI(#REF !1="OK")"

I hope that other users are concerned by this bug and that someone will work over the issu.


Good day

Bunty

UBUNTU 12.04 LTS 64 Bits
GNOME 3.4.0
LibO 3.6.0 RC4 - Libreoffice 3.5.5.3
Comment 7 Markus Mohrhard 2012-08-05 10:10:54 UTC
Is all already fixed in 3-6
Comment 8 SURCOUF 2012-08-05 10:35:20 UTC
(In reply to comment #7)
> Is all already fixed in 3-6

In which version of 3-6, since I installed the RC4 and all of my conditional formatings are altered as explained in my last post. May be it's for the final stable version. If it's the case, I'll await for its arrival.

Bunty

UBUNTU 12.04 LTS 64 Bits
GNOME 3.4.0
LibO 3.6.0 RC4 - Libreoffice 3.5.5.3