Download it now!
Bug 51555 - FORMATTING Not possible to add Conditional formatting
Summary: FORMATTING Not possible to add Conditional formatting
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other All
: medium major
Assignee: Markus Mohrhard
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta3
Keywords: regression
: 51674 51879 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-06-29 05:01 UTC by Cor Nouws
Modified: 2012-07-09 04:06 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot dialog + part of sheet (33.60 KB, image/png)
2012-06-30 01:22 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-06-29 05:01:36 UTC
Open dialog with Format > Conditional formatting
Choose Add
Click (!) on Condition > cell value and ad condition
Click OK
Nothing happens
Open dialog again > no condition defined
Comment 1 Rainer Bielefeld Retired 2012-06-29 14:08:15 UTC
[Reproducible] with Server Installation of  "LibreOffice 3.6.0.0.beta2  German UI/Locale [Build-ID: f010139] on German WIN7 Home Premium (64bit) 

I believe this is an other aspect of "Bug 51507 - FILEOPEN 3.5 document: conditional formatting of type "Formula is" not recognized correctly, lost after saved".

@Markus
What do you think?
Comment 2 Markus Mohrhard 2012-06-29 16:22:16 UTC
(In reply to comment #1)
> [Reproducible] with Server Installation of  "LibreOffice 3.6.0.0.beta2  German
> UI/Locale [Build-ID: f010139] on German WIN7 Home Premium (64bit) 
> 
> I believe this is an other aspect of "Bug 51507 - FILEOPEN 3.5 document:
> conditional formatting of type "Formula is" not recognized correctly, lost
> after saved".
> 
> @Markus
> What do you think?

No, I still don't get what Cor was trying to do but this is not related to an import problem. Looks more like expected behavior when ignoring an invalid entry.

@Cor can you explain for a dumb person like me what to do?
Comment 3 Rainer Bielefeld Retired 2012-06-29 23:14:56 UTC
The problem is indeed related to beta2 (new dialog)

Not reproducible for Markus, so I did a little further research. Might be related to Asian Language / CTL support, problem vanished for me after I had unselected these options (mut might have been coincidence)

Steps to make the problem reproducible for me:
1. Start LibO
2. Menu 'Tools -> Options -> Language Settings', enable Asian Language and
   CTL support,
3. Close LibO (May be with Active quick starter you will have to reboot PC)
4. Launch LibO
5. Click Column Heading B to select column
6. Menu 'Format -> Conditional Formatting', 
7. <Add>
   If yo do not see "chinese" characters in example view the problem will
   not be reproducible
8. Add For Cell contents = 1 "Result", 
   > Example View changes as expected
9. Menu 'Format -> Conditional Formatting', 
   <Add> for cell contents = 2 "Heading"
   > Example View changes as expected
10. <ok>
11. Type "0" to B1, "1" to B2, "2" to B3
    Expected: conditional formatting in B2, B3
    Actual: default formatting for all numbers.
12. Menu 'Format -> Conditional Formatting'
    Expected: conditional formatting info visible
    Actual: empty

But:
====
After I did these tests for a wile, the problem became unreproducible for me
I did not find any way to make it reproducible again, renaming user profile did not restore the problem
Comment 4 Cor Nouws 2012-06-30 01:20:45 UTC
(In reply to comment #2)
> No, I still don't get what Cor was trying to do but this is not related to an
> import problem. Looks more like expected behavior when ignoring an invalid
> entry.
> 
> @Cor can you explain for a dumb person like me what to do?

Hmm, strange. I'll attach a screen shot of what simple thing I do.
Comment 5 Cor Nouws 2012-06-30 01:22:37 UTC
Created attachment 63629 [details]
screen shot dialog + part of sheet

so the screenshot shows what I do
after OK, the cell does not change
open the dialog again... there is no condition defined
Comment 6 Markus Mohrhard 2012-06-30 05:11:30 UTC
Ha, I finally have a bug that might be the problem.

If you only select one cell it seems that we miss this cell and therefore don't assign a conditional format.

I'll look into it.
Comment 7 Not Assigned 2012-06-30 10:14:37 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=53327abd436bf24076f624c56b3dee2f3f0eedcb

handle single cell conditional formats correctly, fdo#51555
Comment 8 Not Assigned 2012-06-30 10:25:29 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86869dea4b76e35ee3ed3d0795f4f7dfc978e7d3&g=libreoffice-3-6

handle single cell conditional formats correctly, fdo#51555


It will be available in LibreOffice 3.6.
Comment 9 Rainer Bielefeld Retired 2012-07-02 22:25:56 UTC
*** Bug 51674 has been marked as a duplicate of this bug. ***
Comment 10 Rainer Bielefeld Retired 2012-07-09 04:06:02 UTC
*** Bug 51879 has been marked as a duplicate of this bug. ***