Bug 51659 - File >> Wizards >> Letter Yields No UI
Summary: File >> Wizards >> Letter Yields No UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: Other Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.0.0
Keywords: regression
: 52562 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-07-02 10:27 UTC by Dave Richards
Modified: 2014-12-06 13:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace. Had to control-C INT to get to the prompt. (2.29 KB, application/x-bzip)
2012-07-03 13:12 UTC, Dave Richards
Details
Strace of crash, started right before entering pulldowns menus. (49.97 KB, application/x-bzip)
2012-07-03 13:13 UTC, Dave Richards
Details
Terminal back on Ubuntu 12.04 (704 bytes, text/plain)
2012-07-07 08:13 UTC, vulcain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Richards 2012-07-02 10:27:04 UTC
Using the 3.6 Daily build from July 2, when I attempt to use the Letter Wizard, the following spewage displays on the command line.  No UI ever opens, and this leaves LibreOffice in a crashed state.  This bug has been around for at least a few weeks and was seen on earlier 3.6 builds.

Java on this server is 1.6.20 (older, I know).  Java upgrade required?


com.sun.star.uno.RuntimeException: string list ressource for id not available
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:175)
	at $Proxy16.getByIndex(Unknown Source)
	at com.sun.star.wizards.common.Resource.getStringList(Resource.java:106)
	at com.sun.star.wizards.letter.LocaleCodes.<init>(LocaleCodes.java:44)
	at com.sun.star.wizards.letter.LetterWizardDialogImpl.initializeNorms(LetterWizardDialogImpl.java:1128)
	at com.sun.star.wizards.letter.LetterWizardDialogImpl.startWizard(LetterWizardDialogImpl.java:178)
	at com.sun.star.wizards.letter.CallWizard$WizardImplementation.trigger(CallWizard.java:114)
Comment 1 Julien Nabet 2012-07-02 14:00:14 UTC
On pc Debian x86-64, with master sources updated today and with 3.5 branch updated today, I don't reproduce the problem. I tried with a brand new LO profile for each test.
I haven't noticed this kind of messages in logs.

Here is my Java version :
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.3) (6b24-1.11.3-2)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Do you reproduce this with other wizards ?
What Linux distribution and which version do you use ?
Do you have any specific LO extension ?
Did you try with a brand new LO profile ?
Comment 2 Dave Richards 2012-07-03 10:22:44 UTC
@julien:
     
 - Just checked and all of the other wizards work fine, the letter wizard works in 3.5 on the same server.
 - The server is running OpenSuse 11.2, understood that this is an older release.
 - No extensions have been installed beyond the defaults
 - Same results with .config/lodev deleted, and also same results with complete removal of the daily builds and clean re-install of the build from July 2nd.

I can strace or gdb if that helps, this is easily replicate.
Comment 3 Julien Nabet 2012-07-03 13:02:35 UTC
Dave: thank you for your detailed feedback.
If you can gdb and/or strace it, yep go ahead. The more we have info the easier for devs it will be to fix the problem.
Comment 4 Dave Richards 2012-07-03 13:11:39 UTC
Attaching files as requested.
Comment 5 Dave Richards 2012-07-03 13:12:26 UTC
Created attachment 63784 [details]
gdb backtrace.  Had to control-C INT to get to the prompt.
Comment 6 Dave Richards 2012-07-03 13:13:03 UTC
Created attachment 63785 [details]
Strace of crash, started right before entering pulldowns menus.
Comment 7 pierre-yves samyn 2012-07-07 08:08:00 UTC
Hello

This wizard doesn't launch with Windows 7 64 bits & Version 3.6.0.0.beta3 (Build ID: 3e2b862)

Others wizards are ok.

worse after trying to start the letter wizard, I can not quit LO must kill the process

Reproduced (fr-discuss) with Ubuntu 12.04 64bits

Regards
Pierre-Yves
Comment 8 vulcain 2012-07-07 08:13:47 UTC
Created attachment 63939 [details]
Terminal back on Ubuntu 12.04

When i try to launch wizard letter on Ubuntu 12.04 64 bit
Comment 9 OfficeUser 2012-07-20 21:24:37 UTC
Maybe related to
https://bugs.freedesktop.org/show_bug.cgi?id=51759

I have the same problem.
Comment 10 OfficeUser 2012-07-20 21:25:52 UTC
Added regression keyword.
Comment 11 Stephan Bergmann 2012-07-24 07:45:51 UTC
This had been fixed on master with <http://cgit.freedesktop.org/libreoffice/core/commit/?id=18b15e48cb1fa7590620930975796a0c0dcac225> "this is the stupidest hard-coded number in the world" but also requires backporting to libreoffice-3-6 and libreoffice-3-6-0.
Comment 12 Not Assigned 2012-07-24 13:20:59 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=117fb70532aeae01327bfe0d828ef8a2d4793b85

fdo#51659: static assertion for STR_ARR_SVT_LANGUAGE_TABLE
Comment 13 Michael Stahl (CIB) 2012-07-24 13:24:07 UTC
should be fixed now on libreoffice-3-6 and libreoffice-3-6-0 branches.
(commit 39afe59baf321c198cfd9c53d69ee8ab301b7d3d)

i've added a static assertion on master so we notice the next time this breaks.
Comment 14 OfficeUser 2012-07-26 20:05:34 UTC
Version 3.6.0.2 (Build ID: 815c576)

...is still affected. Reopened.
Comment 15 OfficeUser 2012-07-26 20:08:24 UTC
@Michael Stahl:

Sorry, your fix seems to be newer than Version 3.6.0.2 (Build ID: 815c576).

I set back to RESOLVED FIXED.
Comment 16 OfficeUser 2012-07-26 20:25:40 UTC
After trying the wizard once, the following behaviour persist:

Can close all documents till a blank GUI appears.

But then neither File/Exit nor X-Button closes the GUI.
Comment 17 OfficeUser 2012-07-26 20:27:22 UTC
My last comment is about
Version 3.6.0.2 (Build ID: 815c576)

@Michael Stahl:
Is this problem also fixed by your patch?
Comment 18 Petr Mladek 2012-07-27 07:39:03 UTC
Yes, also closing is fixed by the fix. LO, gets into some strange state without the patch.
Comment 19 Jean-Baptiste Faure 2014-12-06 13:54:48 UTC
*** Bug 52562 has been marked as a duplicate of this bug. ***