Bug Hunting Session
Bug 51700 - Text to columns puts result into first line if whole column is selected
Summary: Text to columns puts result into first line if whole column is selected
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.1.0
Keywords:
: 67719 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-03 15:31 UTC by rivazza_1
Modified: 2018-05-06 18:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rivazza_1 2012-07-03 15:31:49 UTC
Problem description: When 1st row is blank, text to columns option is shifting data out of line to next row after splitting the column.

Steps to reproduce:
1. Select whole column containing comma separated values (including blank 1st row)
2. Click menu item 'Data' then>> 'Text to Columns'
3. Change 'tab' checkbox to 'comma'
4. Hit Okay

Current behavior: Column splits correctly, but data in the split columns is all shifted up one row.

Expected behavior: Column to split and remain on same row.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Noel Grandin 2012-09-06 14:31:48 UTC
Tested in 3.6.1.2 (Windows)
Comment 2 Jorendc 2013-08-03 23:13:41 UTC
*** Bug 67719 has been marked as a duplicate of this bug. ***
Comment 3 Jorendc 2013-08-03 23:15:08 UTC
See bug 67719.
Comment 4 QA Administrators 2015-04-01 14:41:33 UTC Comment hidden (obsolete)
Comment 5 almos 2015-04-05 22:19:51 UTC
I can't test the latest version, but 4.3.3.2 in Debian Unstable still has this bug.
Comment 6 almos 2015-10-27 23:42:08 UTC
5.0.3 still has this problem.
Comment 7 QA Administrators 2016-11-08 11:52:47 UTC Comment hidden (obsolete)
Comment 8 almos 2016-11-09 00:22:43 UTC
Version 5.2.3.1 no longer has this bug.
Comment 9 Commit Notification 2018-05-06 18:24:39 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9b5c9865d9d193d52e7d728f15ffcb8cfc4d5e4f

uitest for bug tdf#51700

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.