Bug Hunting Session
Bug 67719 - text to columns puts result into first line if whole column is selected
Summary: text to columns puts result into first line if whole column is selected
Status: RESOLVED DUPLICATE of bug 51700
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-03 17:55 UTC by almos
Modified: 2013-08-03 23:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description almos 2013-08-03 17:55:18 UTC
If you have a column of data that you want to process with "text to columns", and you select the whole column by clicking the column header, the result will be created starting on line 1 irregardless of where the original data column started (e.g. your data is in B4:B5000, and it's split into 3 columns, it will end up in B1:D4997).

If there is some data in the area it would overwrite with this (e.g. in the above example you have something else in C1), it asks if it's OK to overwrite it, but in this case it pastes the result in the correct place (B4:D5000 in the example, and C1 is not overwritten).
Comment 1 Jorendc 2013-08-03 23:09:19 UTC
Mmh, I partially can confirm your behavior.

(In reply to comment #0)
> If you have a column of data that you want to process with "text to
> columns", and you select the whole column by clicking the column header, the
> result will be created starting on line 1 irregardless of where the original
> data column started (e.g. your data is in B4:B5000, and it's split into 3
> columns, it will end up in B1:D4997).

I totally can confirm this. Also I have to mention, if you have data from B4:B5000 it'll shift everything to the first row, but it also _DOES NOT_ touch the last 3 rows of it (if your data is in B10:B5000 it'll skip the last 9 rows).

> 
> If there is some data in the area it would overwrite with this (e.g. in the
> above example you have something else in C1), it asks if it's OK to
> overwrite it, but in this case it pastes the result in the correct place
> (B4:D5000 in the example, and C1 is not overwritten).

I fail to confirm that.

Although I fail to reproduce the last part, this is definitely a bug. So marking it as such.

Kind regards,
Joren
Comment 2 Jorendc 2013-08-03 23:13:41 UTC

*** This bug has been marked as a duplicate of bug 51700 ***