Bug Hunting Session
Bug 51908 - Word Count doesn't update immediately when Numbering is applied or removed
Summary: Word Count doesn't update immediately when Numbering is applied or removed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:3.7.0
Keywords: regression
Depends on: 50141
Blocks: Word-Count
  Show dependency treegraph
 
Reported: 2012-07-09 13:27 UTC by Caolán McNamara
Modified: 2019-03-02 12:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caolán McNamara 2012-07-09 13:27:49 UTC
+++ This bug was initially created as a clone of Bug #50141 +++

There remains a problem in the word count in case of paragraph numbering

Steps to reproduce:

1. File> New> Text Document
2. Type "test" then apply numbering (toolbar Formatting)
3. Tools> Word count

Actual result: 1 word, character 4
Expected result: 2 words, 6 characters

see Screenshot after step 3

4. Type <Enter> then Tools> Word count

Actual result: 2 words and six characters
Expected result: 3 words, 8 characters

see Screenshot after step 4

5. Type <Enter>

Actual & Expected results: stop numbering & 6 characters and 2 words

see Screenshot after step 5

The problem seems to be the "pending" status after Step 4. If we redo <enter>
(step 5) will cancel the current numbering. These are the "waiting" numbers
which are not counted ... but they are there and IMHO they should be counted.

Platform: Windows 7 64bits & Version 3.6.0.0.beta3 (Build ID: 3e2b862)
Reproduced on XP (en-discuss)

Regards
Pierre-Yves
Comment 1 Not Assigned 2012-07-09 13:39:00 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=99bd0d846fd2daf4905b986cae4cfb31fde04964

Resolves: fdo#51908 drop word/char count cache when numbering rule changes
Comment 2 pierre-yves samyn 2012-08-25 15:20:40 UTC
Hello

Sorry but still occurs with Version 3.6.1.2 (Build ID: e29a214) and windows 7 64bits (& XP)

Regards
Pierre-Yves
Comment 3 Caolán McNamara 2012-08-27 15:07:46 UTC
move love required to get it to count empty paragraphs when they have numbering applied
Comment 4 Not Assigned 2012-08-27 15:28:50 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a59b51a683a21a44e9071e878addc6a7ace3b5a8

Resolves: fdo#51908 count empty paragraphs if they're numbered
Comment 5 Not Assigned 2012-08-27 15:29:08 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5192468dd49f5e1d821239cd51cea42f8bac7a4b

Related: fdo#51908 reuse the status bar word counts for the dialog
Comment 6 Caolán McNamara 2012-08-27 15:33:49 UTC
seems to work as expected this time