Bug 52301 - PDF Import: Wrong line caps
Summary: PDF Import: Wrong line caps
Status: RESOLVED DUPLICATE of bug 45003
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-20 10:04 UTC by Carolus
Modified: 2013-02-07 21:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
drawing in .PDF format. (11.00 KB, application/pdf)
2012-07-20 10:04 UTC, Carolus
Details
resulting drawing (12.59 KB, application/vnd.oasis.opendocument.graphics)
2012-07-20 10:08 UTC, Carolus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carolus 2012-07-20 10:04:26 UTC
Created attachment 64421 [details]
drawing in .PDF format.

Problem description:importing PDF 

Steps to reproduce:
1. ....import my file pompschakelaar.pdf (attached)
2. ....compare imported resulting drawing with imported file
3. ....

Current behavior: end of line tapering not correct

Expected behavior: right tapering

Platform (if different from the browser): win xp
              
Browser: Firefox/13.0.1
Comment 1 Carolus 2012-07-20 10:08:45 UTC
Created attachment 64422 [details]
resulting drawing
Comment 2 Hashem Masoud 2012-10-04 08:05:07 UTC
(In reply to comment #0)
What do you mean by tapering?
Comment 3 Carolus 2012-10-04 09:31:35 UTC
To whom it may concern:

Sorry for using this misleading word "tapering". Probably I had to use the 
word "cap".

Ends of lines have a shape. They can end with a rectangular, a half circle, a 
triangle or something else.

When you look at the original .PDF file and the drawing created from that file 
by LO draw, you see that originally the ends of the lines are half circles 
whereas in the LO drawing the half circle has been removed and the lines 
have been shortened as a result.

I hope this explanation can be better understand.

Kind regards,

Harry C. Croon
h.c.croon@hccnet.nl



From: bugzilla-daemon@freedesktop.org
To: h.c.croon@hccnet.nl
Subject: [Bug 52301] PDF: importing PDF drawing
Date sent: Thu, 04 Oct 2012 08:05:07 +0000


Hashem Masoud changed bug 52301
                                What
                              Removed
                               Added
                                  
                                                              Status
UNCONFIRMED
NEEDINFO

                                                                  CC

wraithlike@gmail.com

                                                      Ever confirmed

1

Comment # 2 on bug 52301 from Hashem Masoud

(In reply to comment #0)
What do you mean by tapering?

You are receiving this mail because:
*   You reported the bug.
Comment 4 Hashem Masoud 2012-10-06 07:37:39 UTC
(In reply to comment #3)
I get what you mean. You want lines to be rounded at their ends. I tried to do this using: Right-click line ➝ Line ➝ Corner style ➝ Rounded. Nothing changes.

Test done using: Version 3.6.1.2 (Build ID: e29a214) Slackware Linux 13.37

This bug is a duplicate of bug 43209 & bug 44553, I suppose?
Comment 5 Carolus 2012-10-06 12:25:00 UTC
Dear Hashem,

A little correction: I do not want lines to be rounded in general. In importing
.PDF files in draw, I want the same caps for lines as in the .PDF file.
Bug 43209 & bug 44553 seem to demonstrate that draw does not have
features for capping lines other than rectangles. So bug 43209 & bug 44553
need to be solved first, I see.

Kind regards,

Harry



From: bugzilla-daemon@freedesktop.org
To: h.c.croon@hccnet.nl
Subject: [Bug 52301] PDF: importing PDF drawing
Date sent: Sat, 06 Oct 2012 07:37:39 +0000


Hashem Masoud changed bug 52301
                                What
                              Removed
                               Added

                                                              Status
NEEDINFO
NEW

                                                                  CC

rb.henschel@t-online.de

Comment # 4 on bug 52301 from Hashem Masoud

(In reply to comment #3)
I get what you mean. You want lines to be rounded at their ends. I
tried to do
this using: Right-click line  Line  Corner style  Rounded.
Nothing changes.

Test done using: Version 3.6.1.2 (Build ID: e29a214) Slackware Linux
13.37

This bug is a duplicate of bug 43209 & bug 44553, I suppose?

You are receiving this mail because:
*   You reported the bug.
Comment 6 Samuel Mehrbrodt (CIB) 2013-02-07 21:15:50 UTC

*** This bug has been marked as a duplicate of bug 45003 ***