Download it now!
Bug 52333 - EDITING: Copying cell with conditional formatting CRASH when paste overwrites source cell
Summary: EDITING: Copying cell with conditional formatting CRASH when paste overwrites...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.2 rc
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:3.6.0) (target:3.7.0)
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-07-21 05:54 UTC by pierre-yves samyn
Modified: 2015-12-22 01:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (18.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-07-21 06:57 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2012-07-21 05:54:07 UTC
Hello

Steps to reproduce:

1. File> New> Spreadsheet
2. Select B2, Format> Conditional formatting> Conditional formatting> Add > "Value is equal to" : 2, Apply style : Result
3. Enter 2 in B2
4. Select B2<Ctrl><C> (or Edit> Copy)
5. Select any cell, B2 included, e.g. B1:B4
6. <Ctrl><V>

Crash...

This is reproduction, *step by step* of bug 50679, comment 0

(others comments seems to treat the case when the destination of the copy does not include the copied cell)


If this could help, I add that in step 6 the crash also occurs with Edit> Paste special> Selection: Format 

And, of course, it also occurs if we replace steps 4-6 by:
4. Select B2, 
5. On the Standard Bar, click the Format Paintbrush icon.
6. Applies to B1:B2

Crash...

Platform:  windows 7 64bits

Reproduced (fr-discuss) with beta3 and 3.6.0.1
Comment 1 Rainer Bielefeld Retired 2012-07-21 06:56:23 UTC
[Reproducible] with attached sample document (created with 3.5.5.3) and Server Installation of  "LibreOffice 3.6.0.2 rc  German UI/Locale [Build-ID:  815c576] on German WIN7 Home Premium (64bit) 

Steps how to reproduce:
0. open sample document
1. Click Be
   Cell cursor appears around B2
2. <control+c> for Copy
3. select B1:B4 with mouse
4. <control-V>
   Bug: Crash 

@pierre-yves samyn:
The confusion in  Bug 50679 has been caused by my sample document. I stumbled about Bug 50679 checking whether a crash I had observed already had been reported, and found that one and because it also was concerning something with copy - paste - conditional formatting; I assumed that that might be the same as mine. But as we no know after Markus' fix for my problem we know that my problem only was similar, but not identical to mariosv's problem

@Markus:
Can you please check?
Comment 2 Rainer Bielefeld Retired 2012-07-21 06:57:28 UTC
Created attachment 64482 [details]
Sample Document
Comment 3 pierre-yves samyn 2012-07-21 07:33:06 UTC
(In reply to comment #1)
> The confusion in  Bug 50679 has been caused by my sample document.

This is what I understood.


> my problem only was similar, but not identical to mariosv's problem

what's the word that no one understands in "is not the same" ;-) 

QA is difficult. I respect and admire your work, as well as developers...

Thank you...

Regards
Pierre-Yves
Comment 4 Rainer Bielefeld Retired 2012-07-21 07:56:58 UTC
No crash when I copy / paste a cell range containing the conditional formatting, in example when I select B2:B3 in Step 2 of original report no crash in step 6

And indeed that's a Regression.

Already [Reproducible] with Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a502549]" (tinderbox: Win-x86@6-fast, pull time 2012-05-31 07:33:55)


Still worked fine with 
- MinGW 2012-04-26
- Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)
Comment 5 Rainer Bielefeld Retired 2012-07-21 08:10:05 UTC
Currently I only reproduce the Crash when I copy Paste
- a single Cell
- when paste overwrites source cell

I amended Summary, please feel free to revert or improve!
Comment 6 Markus Mohrhard 2012-07-23 17:24:41 UTC
I can't reproduce this one with a master build. Let me check with a 3-6 build.
Comment 7 Markus Mohrhard 2012-07-26 15:05:00 UTC
I can't reproduce with a latest 3-6 build.
Comment 8 Rainer Bielefeld Retired 2012-07-26 15:54:18 UTC
I can confirm that progress with parallel installation of Master "LOdev " 3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 66e4540]" (tinderbox:Win-x86@6, pull time 2012-07-26 02:09:47), so WFM for NOW
Comment 9 pierre-yves samyn 2012-08-25 12:42:09 UTC
Hello

WORKSFORME with Version 3.6.1.2 (Build ID: e29a214) (Windows 7 64bits & Windows XP)

Regards
Pierre-Yves
Comment 10 Robinson Tryon (qubit) 2015-12-22 01:33:04 UTC
Removing comma from Whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
[NinjaEdit]