Download it now!
Bug 52386 - FILEOPEN: Import RTF file is incorrect, document is corrupt
Summary: FILEOPEN: Import RTF file is incorrect, document is corrupt
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF
  Show dependency treegraph
 
Reported: 2012-07-23 09:54 UTC by Andrey Gankov
Modified: 2017-03-06 12:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF (44.16 KB, application/rtf)
2012-07-23 09:54 UTC, Andrey Gankov
Details
LO 3.5 (125.52 KB, image/png)
2012-07-23 09:54 UTC, Andrey Gankov
Details
2003 (114.85 KB, image/png)
2012-07-23 09:56 UTC, Andrey Gankov
Details
The document with LO 4.1.1 (54.42 KB, application/pdf)
2013-10-03 20:02 UTC, Teo91
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Gankov 2012-07-23 09:54:04 UTC
Created attachment 64535 [details]
RTF

Attached RTF document open incorrect. Something in document is shifted. Some text is over another text.
See screen shot of this document in Office 2003. In 2003 document is correct.
Comment 1 Andrey Gankov 2012-07-23 09:54:52 UTC
Created attachment 64536 [details]
LO 3.5
Comment 2 Andrey Gankov 2012-07-23 09:56:10 UTC
Created attachment 64537 [details]
2003
Comment 3 Teo91 2013-10-03 20:01:31 UTC
I can confirm this bug with LO 4.1.1: the import is really improved, but some lines in the document are still lost, while the text is correctly placed.

See the attachment for LO 4.1.1.
Comment 4 Teo91 2013-10-03 20:02:23 UTC
Created attachment 87088 [details]
The document with LO 4.1.1
Comment 5 Alexandr 2014-08-06 12:37:44 UTC
> some lines in the document are still lost, while the text is correctly placed.

Reproducible with LibreOffice 4.2.5 and 4.3.0 on Debian.
Comment 6 QA Administrators 2015-09-04 02:48:27 UTC Comment hidden (obsolete)
Comment 7 Alexandr 2015-09-19 16:51:55 UTC
In LibreOffice 5.0.1 the part under "Назначение платежа" moves to the second page.
Comment 8 Robinson Tryon (qubit) 2015-12-10 01:08:18 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-01-03 19:42:18 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2017-03-06 12:27:22 UTC
*** Bug 106354 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2017-03-06 12:46:43 UTC
it seems the original problem was solved. The problem commented in comment 7 has been reported in bug 106354. Closing this one as RESOLVED WORKSFORME