Download it now!
Bug 52985 - When saving read only file to another location file isn't automaticaly write enabled
Summary: When saving read only file to another location file isn't automaticaly write ...
Status: RESOLVED DUPLICATE of bug 53280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard:
Keywords:
: 53326 53714 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-31 05:09 UTC by Mikeyy - L10n HR
Modified: 2012-08-24 08:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikeyy - L10n HR 2012-07-31 05:09:51 UTC
3.5.5 behaviour:

1. Open read only xls file
2. Go File - Save As
3. Save it do desired write enabled location
4. File is ready for editing as soon as you save.

3.6.0.4 behaviour:

1. Open read only xls file
2. Go File - Save As
3. Save it do desired write enabled location
4. File is still READ-ONLY
5. Press Edit File icon from toolbar
6. File is ready for editing.

Why did you introduce unneeded extra step in LO 3.6.0.4?
Comment 1 Stephan Bergmann 2012-07-31 08:09:21 UTC
This might be an unintended consequence of <http://cgit.freedesktop.org/libreoffice/core/commit/?id=b9ecec7c74687ed5a9470cffb7d02e0e6e83107e> "Allow for editing of read-only documents."  I will have a look.
Comment 2 billhook 2012-08-24 01:15:22 UTC
*** Bug 53326 has been marked as a duplicate of this bug. ***
Comment 3 billhook 2012-08-24 01:15:50 UTC
*** Bug 53714 has been marked as a duplicate of this bug. ***
Comment 4 Stephan Bergmann 2012-08-24 08:16:20 UTC

*** This bug has been marked as a duplicate of bug 53280 ***