Download it now!
Bug 53163 - Crosshatching is spilling out of objects when printed/pdf exported
Summary: Crosshatching is spilling out of objects when printed/pdf exported
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: All All
: medium critical
Assignee: David Tardon
URL:
Whiteboard: target:4.1.0 target:3.6.7 target:4.0.4
Keywords:
: 44785 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-06 14:08 UTC by skiani
Modified: 2013-06-28 09:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Drawing illustrates problem with simple graphic, complex graphics are the same/worst. (43.57 KB, application/vnd.oasis.opendocument.presentation)
2012-08-06 14:08 UTC, skiani
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skiani 2012-08-06 14:08:12 UTC
Created attachment 65179 [details]
Drawing illustrates problem with simple graphic, complex graphics are the same/worst.

Graphic objects that hatched filling are not rendered correctly when being exported or printed to PDF. This can make a really huge mess out of complex drawings. Marked as Linux but likely affects other platforms similarly.
Comment 1 skiani 2012-12-05 17:32:39 UTC
Problem is persistent is latest release. Also a cross platforms. Seems like a pretty major problem (it is at least for me) not being able to print figures without them looking terrible.
Comment 2 skiani 2012-12-07 14:08:38 UTC
3.6.4 still broken. Affects all LO applications.
Comment 3 Commit Notification 2013-04-26 15:34:59 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=092fa33f22bbdcb74c3533750158db1724971878

fdo#53163 fix hatching for objects with curves



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Stephan van den Akker 2013-04-29 12:44:54 UTC
Just tested with:

Version 4.0.2.1 (Build ID: 400m0(Build:1)) on openSuSE 11.4 (64-bit, a build from 
before the cherry pick of the commit mentioned in comment 3)
AOO 3.4.1 (build 9593) on Windows XP-SP3

Both versions exhibit the problem in the OP when the document is exported tot PDF.

Also tested with:

Version: 4.1.0.0.alpha0+
Build ID: 706e3b8e43df94310b2fe8458da67875073a046

on openSuSE 11.4 (64-bit). This build includes the patch mentioned in comment 3. 
I can confirm that this version solves the problem (tested with PDF export).

Thanks David!
Comment 5 Commit Notification 2013-04-30 07:27:08 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98bffe149346077a9866f372fa0080dfb533c0e5&h=libreoffice-3-6

fdo#53163 fix hatching for objects with curves


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-04-30 07:27:27 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=728220af3af776e1a759b6051b669e87c511362d&h=libreoffice-4-0

fdo#53163 fix hatching for objects with curves


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 ign_christian 2013-06-28 09:31:36 UTC
*** Bug 44785 has been marked as a duplicate of this bug. ***