Bug Hunting Session
Bug 53360 - : Conditional Spacing between paragraphs
Summary: : Conditional Spacing between paragraphs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 54783 54960 57038 64619 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-10 22:25 UTC by Marcos
Modified: 2014-02-09 13:29 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
. (191.79 KB, image/png)
2012-08-12 03:25 UTC, João Mac-Cormick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos 2012-08-10 22:25:28 UTC
Problem description: 

Steps to reproduce:
1. Open Format -> Paragraph. Under the tab Indents and Spacing, there's the option "Don't add space between paragraphs of same style".
2. Right-click any style then click Modify. Under the same tab Indents and Spacing, the option isn't there.

Current behavior:
The option for contextual spacing only exists in the paragraph window if you don't use styles.

Expected behavior:
It shoulb be possible to choose the option for contextual spacing in a per style basis.

I'm using Libre Office 3.6.0.4 under Windows 7 Ultimate 64 bits. Both user interfaces (Windows and LibreOffice are in Brazilian Portuguese).

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 João Mac-Cormick 2012-08-12 03:25:13 UTC
Created attachment 65448 [details]
.
Comment 2 João Mac-Cormick 2012-08-12 03:26:52 UTC
Failure also confirmed in version windows xp 32 bits.

The option "do not add space between paragraphs of same style" does not appear to modify the style.
Comment 3 João Mac-Cormick 2012-08-21 03:01:10 UTC
Problem still exists in version 3.6.1.rc1

Workaround

1) Creates the style (F11), checking "Autoupdate".
2) Apply to a paragraph style created.
3) Formats the paragraph and checking "contextual spacing" (Don't add space between paragraphs of the same style).
4) If you prefer, modify the style unchecking "Autoupdate".
Comment 4 João Mac-Cormick 2012-08-25 22:43:04 UTC
Problem still exists in version 3.6.1.rc2
Comment 5 Marcos 2012-08-30 00:12:56 UTC
Bug is still present in version 3.6.1.2.
Comment 6 2012-09-13 14:02:02 UTC
*** Bug 54783 has been marked as a duplicate of this bug. ***
Comment 7 pierre-yves samyn 2012-09-15 15:09:01 UTC
*** Bug 54960 has been marked as a duplicate of this bug. ***
Comment 8 Marcos 2012-10-05 11:46:45 UTC
Bug still exists in version 3.6.2.2.
Comment 9 Marcos 2012-10-19 11:17:52 UTC
Bug still exists in version 3.6.3.1
Comment 10 Jean-Baptiste Faure 2012-11-03 14:46:53 UTC
Please do not change version number, it shows the oldest version in which the bug has been found.

Best regards. JBF
Comment 11 João Mac-Cormick 2012-12-10 16:54:51 UTC
Bug still exists in version 3.6.4.3
Comment 12 João Mac-Cormick 2012-12-10 16:55:17 UTC
Bug still exists in version 4.0 alpha 1.
Comment 13 Ákos 2012-12-11 09:16:26 UTC
Bug still exists in version 4.0 beta 1.
Comment 14 László Németh 2013-01-14 08:07:50 UTC
The style-level conditional spacing between paragraphs is still missing from beta 2. (It is possible to select and format all related paragraphs with the “search for styles” option of the Find & Replace dialog, but I have used the following style-level workaround: invisible (in fact, white) borders with “merge with next paragraph” option and with top and bottom context spacing.)
Comment 15 László Németh 2013-02-14 10:01:26 UTC
@Miklos, could you check this issue. Thanks in advance, Laci
Comment 16 László Németh 2013-02-14 10:06:39 UTC
*** Bug 57038 has been marked as a duplicate of this bug. ***
Comment 17 László Németh 2013-02-14 10:08:45 UTC
Thanks to the Bug 57038, it seems, it is only a dialog problem. There are workarounds, eg. using AutoUpdate of Organizer page of the styles, and simple paragraph formatting will modify the style settings.
Comment 18 László Németh 2013-02-14 11:44:21 UTC
(In reply to comment #17)
> Thanks to the Bug 57038, it seems, it is only a dialog problem.
Oops, I haven't read the comments, also thanks to João Mac-Cormick!
Comment 19 Urmas 2013-05-15 18:47:07 UTC
*** Bug 64619 has been marked as a duplicate of this bug. ***
Comment 20 João Mac-Cormick 2013-07-20 19:54:57 UTC
Bug still exists in version 4.0.4.2.
Comment 21 Marcos 2013-07-25 22:07:17 UTC
Bug is still present in version 4.1.0.4.
Comment 22 João Mac-Cormick 2013-10-06 17:17:52 UTC
Bug is still present in version 4.1.1.2.
Comment 23 João Mac-Cormick 2013-10-31 15:52:18 UTC
Bug is still present in version 4.1.2.3.
Comment 24 Marcos 2013-11-04 03:16:30 UTC
Bug is still present in version 4.1.3.2.
Comment 25 Marcos 2014-02-06 00:24:09 UTC
Bug is solved in version 4.2.
Comment 26 João Mac-Cormick 2014-02-09 13:29:47 UTC
(In reply to comment #25)
> Bug is solved in version 4.2.

Obrigado Marcos pelos testes na 4.2.0. Atualizarei a wiki 3.6.

João Mac-Cormick