Bug Hunting Session
Bug 53551 - DOCX import: Wrong inter-paragraph spacing with before/after="auto": Should be one line not 0pt
Summary: DOCX import: Wrong inter-paragraph spacing with before/after="auto": Should b...
Status: RESOLVED DUPLICATE of bug 48350
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-15 18:35 UTC by Tobias Burnus
Modified: 2014-03-28 08:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2012-08-15 18:35:06 UTC
When looking at the screenshots of bug 36999, I realized that LibreOffice 3.6 uses the wrong paragraph spacing in a text box.


The following is about the text in the box on the bottom right of the screenshots.

With paragraph before=auto, after=auto, Microsoft Office 2010/Windows shows the following:  attachment 65551 [details]
Namely, there is an empty line between the paragraphs.

However, result of LibreOffice is attachment 65607 [details]
Namely, there is no spacing after the paragraph.


Test case: https://bugzilla.novell.com/attachment.cgi?id=394228


From ECMA-376 3rd edition Part 1:
"17.3.1.33 spacing (Spacing Between Lines and Above/Below Paragraph)"

"afterAutospacing
(Automatically
Determine Spacing
Below Paragraph)"

[...] "This automatic spacing shall match the spacing which would be applied to the paragraph in an HTML document where no explicit spacing before/after is specified."

That's of cause "well defined" as a view at the HTML 4.01 standard shows:
http://www.w3.org/TR/1999/REC-html401-19991224/struct/text.html#h-9.3.1

However, most graphical HTML browsers seem to use a spacing which is (roughly?) as high as one line of the rendered text.
Comment 1 Joel Madero 2013-06-10 15:59:11 UTC
Hm I'm trying to understand what the focus is here. 

Is the focus the fact that there is the extra frames that are seen in the png's that is circled in the thick red? Or are we looking for something else.

Thanks for your patience on this, for now marking as NEEDINFO - just want to clarify what exactly I'm looking for. I can confirm the extra frame seen in the red circle on 4.2 master but I think the summary is telling me to look at something else :)

If it's line spacing, where exactly am I looking? Another image with highlighted pen would be nice but if not, just tell me where to look.

Once you provide a bit of clarification, mark as UNCONFIRMED and I'll get to it. Thanks!
Comment 2 Tobias Burnus 2013-06-10 16:30:50 UTC
(In reply to comment #1)
> Is the focus the fact that there is the extra frames that are seen in the
> png's that is circled in the thick red? Or are we looking for something else.

No, that's bug 36999.

> If it's line spacing, where exactly am I looking? Another image with
> highlighted pen would be nice but if not, just tell me where to look.

Look at the box at the bottom right:

+----------------------------------
| Benchmark by Therma-Tru ...
| Smooth Fiber ...
|   <<<<<<<<< Missing empty line
| Item #228...
|   <<<<<<<<< Missing empty line
| ***** (1 Review)
|   <<<<<<<<< Missing empty line
| $183.00
+----------------------------------

In MS Office, there is the empty line (attachment 65551 [details])
In LO there is *no* empty line (attachment 65607 [details])
Test case: https://bugzilla.novell.com/attachment.cgi?id=394228

See comment 0 why there has to be an empty line.
Comment 3 Jorendc 2013-06-25 22:38:59 UTC
Hi Tobias, Joel, *,

I can confirm mentioned behavior of Tobias with provided test document and attachment. Tested and compared with Mac OSX 10.8.3 with LibreOffice 4.1.0.1 RC and Word for Mac 2011. LibreOffice indeeds lacks vertical space between the text and the blue 'stars'.

Thanks Tobias for your nice bug report and reply to Joel' questions.

Kind regards,
Joren
Comment 4 Kevin Suo 2014-03-28 08:17:12 UTC

*** This bug has been marked as a duplicate of bug 48350 ***