Download it now!
Bug 53592 - FILEOPEN Mouse cursor over Base Icon in XP causes Explorer crash
Summary: FILEOPEN Mouse cursor over Base Icon in XP causes Explorer crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard: target:3.7.0 target:3.6.2
Keywords:
: 54689 55179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-16 15:08 UTC by Paul Mirowsky
Modified: 2012-09-21 13:08 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Mirowsky 2012-08-16 15:08:26 UTC
When hover mouse cursor over file icon on Writer or Calc document, File information is displayed.  When hovering mouse cursor over Base document Icon, causes Windows Explorer to crash.

Probable cause: bad header definition
Comment 1 Alex Thurgood 2012-08-21 15:20:17 UTC

*** This bug has been marked as a duplicate of bug 53420 ***
Comment 2 Andras Timar 2012-08-21 19:49:11 UTC
 	msvcr90.dll!__crt_debugger_hook(int _Reserved=108849320)  Line 65	C
 	msvcr90.dll!_invoke_watson(const wchar_t * pszExpression=0x0000000000000000, const wchar_t * pszFunction=0x000000007bcb9ccc, const wchar_t * pszFile=0x000000006b9576a9, unsigned int nLine=1804957134, unsigned __int64 pReserved=0)  Line 233	C++
 	msvcr90.dll!_invalid_parameter(const wchar_t * pszExpression=0x00000000067cf088, const wchar_t * pszFunction=0x000000000de1e2f0, const wchar_t * pszFile=0x00000000067cf0b8, unsigned int nLine=1804956640, unsigned __int64 pReserved=0)  Line 115	C++
 	msvcr90.dll!_invalid_parameter_noinfo()  Line 126	C++
>	shlxthdl_x64.dll!CBaseReader::Initialize(const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & ContentName="Ü ")  Line 86 + 0x18 bytes	C++
 	shlxthdl_x64.dll!CMetaInfoReader::CMetaInfoReader(const std::basic_string<char,std::char_traits<char>,std::allocator<char> > & DocumentName="Ü ")  Line 68 + 0x20 bytes	C++
 	shlxthdl_x64.dll!CInfoTip::GetInfoTip(unsigned long __formal=0, wchar_t * * ppwszTip=0x0000000007255730)  Line 222 + 0x22 bytes	C++
 	shell32.dll!000007fefe51a562()
Comment 3 Andras Timar 2012-08-21 19:50:46 UTC
I think it is different than bug 53420.
Comment 4 Jochen 2012-08-23 18:39:03 UTC
(In reply to comment #3)
> I think it is different than bug 53420.

Why?
Comment 5 Not Assigned 2012-08-27 14:38:53 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40c85b88ad0351acaf59fd2372676cdb8ca452d6

fdo#53592: Try not to crash on empty m_ZipContent
Comment 6 Not Assigned 2012-08-27 14:45:35 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f33979fc875abe827b42d35ac4fc4304e4a4d7b

.odb files do not have thumbnail image (related: fdo#53592)
Comment 7 Not Assigned 2012-08-27 14:51:48 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c828a2fe53b7dede97d9b3b69462db22fb496685&g=libreoffice-3-6

fdo#53592: Try not to crash on empty m_ZipContent


It will be available in LibreOffice 3.6.2.
Comment 8 Not Assigned 2012-08-27 14:58:06 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7695e138950168bc07669f13abc5498308890b5c&g=libreoffice-3-6

.odb files do not have thumbnail image (related: fdo#53592)


It will be available in LibreOffice 3.6.2.
Comment 9 Andras Timar 2012-09-14 07:06:27 UTC
*** Bug 54689 has been marked as a duplicate of this bug. ***
Comment 10 pierre-yves samyn 2012-09-21 09:15:56 UTC
*** Bug 55179 has been marked as a duplicate of this bug. ***
Comment 11 ribotb 2012-09-21 13:08:39 UTC
With LO 3.6.2.1 no more crash When hovering mouse cursor over Base document Icon.

Bernard Ribot