Download it now!
Bug 54689 - Windows explorer or TotalCommander crash when pointing to a *.ODB file
Summary: Windows explorer or TotalCommander crash when pointing to a *.ODB file
Status: RESOLVED DUPLICATE of bug 53592
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 38913
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 11:29 UTC by Luzius Auer
Modified: 2012-09-14 07:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luzius Auer 2012-09-09 11:29:05 UTC
Windows Explorer and Christian Ghisler's Total Commander 8.01 crash after a few seconds when pointing to a *.ODB Database. The databases themselves operate normally.
The Windows crash message hints to "msvcr90.dll".

This behavior is verified on Win7_64, WinXP32 on three machines with LO 3.6.0 and LO 3.6.1. with all such databases (all internal HLSQL).
After reverting to 3.5.6 the problem disappears, so it looks like a LO3.6 problem.

Luzius
Comment 1 Julien Nabet 2012-09-09 15:02:24 UTC
It must be related with fdo#38913
Comment 2 Andras Timar 2012-09-14 07:06:27 UTC
It is rather a duplicate of bug 53592, at least the fix I committed there solved this issue, too. Windows Explorer shell extension tried to extract thumbnail image from .odb file, but .odb does not have thumbnail image. Fridrich fixed the crash and I unregistered the thumbnail viewer for .odb, so this bug should not re-occur in 3.6.2 and later.

*** This bug has been marked as a duplicate of bug 53592 ***