Download it now!
Bug 53921 - CRASH with error message "...stopped working" when launch
Summary: CRASH with error message "...stopped working" when launch
Status: RESOLVED DUPLICATE of bug 38913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta3
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-22 08:28 UTC by narayanaras
Modified: 2012-09-05 08:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2012-08-22 08:28:35 UTC
As soon as I launch LibreOffice 3.6, it stops working.

This is the same PC (with Win 7 OS) that had "crash-on-start" problem with LibO 3.6 beta.

The error message is as follows:

Problem signature:
  Problem Event Name:	BEX
  Application Name:	soffice.bin
  Application Version:	3.6.0.104
  Application Timestamp:	5012ee18
  Fault Module Name:	MSVCR90.dll
  Fault Module Version:	9.0.30729.6161
  Fault Module Timestamp:	4dace5b9
  Exception Offset:	0002e9f4
  Exception Code:	c0000417
  Exception Data:	00000000
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	16393
  Additional Information 1:	c030
  Additional Information 2:	c0302268d218b5aee8d4592c19418738
  Additional Information 3:	5a57
  Additional Information 4:	5a5741c81ed2416ab34dd0189ce41920

***************************
In a possibly related event, my Firefox 15.0 complained about Java module and closed it down (this probably refers to JRE that got installed when I installed JDK7 u3.)

Should I delete the user profile and retry?
Comment 1 Rainer Bielefeld Retired 2012-08-22 08:55:59 UTC
NOT reproducible with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit) 

@reporter:
THE world famous start up problem? A little more info would help.
<https://wiki.documentfoundation.org/QA-FAQ#How_to_cite_other_Libreoffice_Bugs_in_FDO_Bugzilla>

Unfortunately important information is missing in your report.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list.

Please test with 3.6.1.1 or later, what works much better, before any other activity. We will not invest any manpower into a bug only reproducible with a very obsolete Beta.

Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- add information 
  -- what EXACTLY is unexpected (stops working, what does that mean? Crash?
     Disappears silently? ...?)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO  localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- What other 3.6 Crash Bugs did you already check whether they are
    concerning the same problem?
  -- everything else crossing your mind after you read linked texts
Comment 2 narayanaras 2012-08-22 10:09:54 UTC
Well, 3.6.1.1 is a PRE-release. So I thought problems in the stable version (3.6) should be reported regardless of what's in it.

AFAIK I HAVE shared all relevant info.

The only two additional items I can think of are-

(a) The program stops working, and windows says "Libreoffice 3.6 has stopped working".

(b) I clicked on the LO in in the launch bar to launch the program.
Comment 3 narayanaras 2012-08-22 10:13:39 UTC
BTW I deleted the Extension folder in my user profile, but that did not help.
LO still stops working as soon as I launch it.

I have also uninstalled JDK7u3 and installed a fresh copy of JDKu6.

But the problem still exists.

****
I will install 3.6.1.1 tomorrow and report.
Comment 4 Rainer Bielefeld Retired 2012-08-22 10:34:04 UTC
Might be DUP of "Bug 51252 - LO cannot start (reports runtime error with Visual C++ Runtime Library)"

Reporter's dump looks similar to the one in "Bug 52017 - CRASH when launch on Win 7 x64"

@reporter:
64 bit?
Comment 5 narayanaras 2012-08-22 15:29:19 UTC
Well, Bug#51252 was also reported by me. 

But this time the symptoms are different.

This time the GUI goes "all white" (foggy) and the Windows pops up the message "LibreOffice 3.6 has stopped working". 

It offers two options to the user:
(a) find solution on the web and close the program, 
(b) Close the program.

This is distinct from the runtime error reported in bug#51252.

Besides, I already have reported that deleting the extension folder does not resolve the issue.

That said, there is a common factor also: 

Out of my two PCs (both running win 7), only one suffered from Bug#51252. The other PC was not affected at all. This bug has affected them in exactly the same way. But now deleting the extension folder does not resolve the issue.
Comment 6 narayanaras 2012-08-22 15:30:53 UTC
Out of the two PCs, the "OK" PC has 32-bit Windows Ultimate OS.
I will report the other OS type tomorrow.

Thanks.
Comment 7 Rainer Bielefeld Retired 2012-08-22 15:41:37 UTC
@narayanaras:
Please also try to rename complete profile folder, not only extensions folder
Thank you for your patience!
Comment 8 narayanaras 2012-08-22 16:08:52 UTC
oh that's something new. 
(Just to clarify, I didn't have to do that as workaround in bug#51252...)

In this case, could you please tell me which folder to rename in the following chain?

C:\Users\<MyUserName>\AppData\Roaming\LibreOffice\3\user\extensions

Thanks in advance!
Comment 9 Rainer Bielefeld Retired 2012-08-23 05:02:04 UTC
Simply modify the "3" in "\LibreOffice\3\user\"
I am not optimistic that that will heal the problem, but that's the most simple test.
Comment 10 narayanaras 2012-08-23 05:42:04 UTC
Here is the remaining feedback about the OS version:

The "Not OK" PC has 32-bit Win7 Professional, SP-1.
(In comparison, the "OK" PC has 32-bit Win7 Ultimate.)
***

@Renaming the "3" folder in the user profile path:
I did that. 
When I started LO after that, it re-created a "3" folder (and subfolders).

Note: In the following description, I have clicked on the LO's icon in the launch bar to launch LO. I did not use any other method (such as clicking on a file associated with LO). But if you think it is necessary, I will repeat the experiment exactly as you wish.

The flash screen lasted for 2-3 minutes (showing status that LO is loading various components). But after that it just vanished. I tried to launch LO a couple of times, with the same result. (Each time the flash screen vanished).

I kept on trying. But it stopped responding totally (No flash screens also).

Finally I checked the Process Explorer, and found 6-7 sets of soffice.exe. Apparently each of these processes had launched an instance of soffice.bin.

In other words, I saw 6-7 sets of-
soffice.exe
\_soffice.bin

And that's not all: I also saw an equal number of soffice.bin (or was that exe?) running on their own (not a bin-exe pair).

I killed them all, and again launched LO. This time it got launched OK.

I was about to install 3.6.1.1 on this PC. Should I go ahead or wait for further instructions?

Thanks in advance

-Narayan
Comment 11 Rainer Bielefeld Retired 2012-08-23 06:53:51 UTC
(In reply to comment #10)
> When I started LO after that, it re-created a "3" folder (and subfolders).

That's expected
> The flash screen lasted for 2-3 minutes (showing status that LO is loading
> various components). But after that it just vanished. 

The vanishing might be caused by an other "Bug 43989 - After installation first launch terminates after splash screen". That should have been fixed for 3.6.0.0.beta2, but I do not know whether anything is known concerning remaining damages caused by that bug

> I tried to launch LO a
> couple of times, with the same result. (Each time the flash screen vanished).

I doubt that that can be explained by that "other bug"

> Finally I checked the Process Explorer, and found 6-7 sets of soffice.exe.
> Apparently each of these processes had launched an instance of soffice.bin.

I think that is a result of your problem, not the reason

> I killed them all, and again launched LO. This time it got launched OK.

That is interesting, My experience with Bug 43989 was that the soffice.bin was terminated after the silent crash, but there might have been variants.

> I was about to install 3.6.1.1 on this PC. Should I go ahead or wait for
> further instructions?

Currently I am tending to hope that you suffered from an "aggressive variant" of  Bug 43989. I recommend to install 3.6.1.1 (what works much better than 3.6.0) and to start with a new user profile. There were lots of problems (most in bundled extensions) and the fixing still is in progress.

But please keep you replaced profile, if your problem reappears comparison of profile versions might help to understand you problem.
Comment 12 narayanaras 2012-08-23 07:26:39 UTC
ok. So should I copy just the "3" folder, or any of the parent folders?

BTW I can compare the folders between the OK and the not ok PCs, if you want. I can send you diff between non-text files too.
Comment 13 Rainer Bielefeld Retired 2012-08-23 08:03:17 UTC
(In reply to comment #12)
> ok. So should I copy just the "3" folder, or any of the parent folders?

Copy? For your 3.6.1 I recommend to start with a new Profile, if there is not \3\ LibO will create such a new file

> BTW I can compare the folders between the OK and the not ok PCs, if you want.

I'm afraid you will have to sort out lots of irrelevant differences, and I am afraid currently nobody can use your results. So I would recommend to avoid that work if you are successful with your 3.6.1 installation
Comment 14 narayanaras 2012-08-23 09:03:17 UTC
From Comment#13:
>Copy?

Well, in comment#11, you advised me to- 
>But please keep you replaced profile, if your problem reappears comparison of
>profile versions might help to understand you problem.

(see the last line).

Since LO does not have a built-in command to save a user profile, I thought that the only way to save a profile is to save the "3" folder. 

In that context, I had a doubt--
Which folder should I save: Just the "3" folder or a parent folder?

*****
And since you mentioned analysis of the problem by comparing the profile folders, it struck me that we already two PCs for such comparison.

But comment#13 reverses that logic.

If comparing folders is going to be too difficult a task, we may as well drop the idea of saving the profile.

******
So what should I do- follow your comment#11 or 13?

Comment#11 says I should save folder (which?) and install 3.6.1.1.
comment#13 says I should close LO, delete "3" folder and then install 3.6.1.1.
(This option does NOT save a profile for later comparison).

Awaiting advise... (will hold off installation of 3.6.1.1 till then)
Comment 15 Stephan Bergmann 2012-09-05 08:42:57 UTC
Windows exception code c0000417 and offset 0002e9f4 in msvcr90.dll indicate this is a duplicate of Bug 38913.

*** This bug has been marked as a duplicate of bug 38913 ***