Bug Hunting Session
Bug 53984 - Open existing Table or Report of particular document only possible after Registration of DB (?)
Summary: Open existing Table or Report of particular document only possible after Regi...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-23 21:58 UTC by Jochen
Modified: 2012-08-26 09:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
odb-file don´t work (24.02 KB, application/vnd.sun.xml.base)
2012-08-23 22:03 UTC, Jochen
Details
error message (6.85 KB, image/png)
2012-08-24 18:45 UTC, Jochen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2012-08-23 21:58:54 UTC
The odb-file "ReportBuilder_Textfields_without_Contentmarker.odb" (see attach 1) can´t be used without a registration in LibreOffice.
"can´t be used" means:
odb-file can be opened, but the table "Article" and/or the report "Report" can´t be opened.

OS: Windows XP or Windows 7 64 bit

### Important information ###
After registration odb-file can be opened (logically). But:
After de-registration, i.e. removing the odb-file in Tools -> Options -> LibreOffice Base -> Database -> Registered databases, and open the odb-file again the odb-file works fine, i.e. the table "Article" and/or the report "Report" can be opened.

This problem have discussed on German discuss-ML [1] and on international QA-ML [2].
[1] http://listarchives.libreoffice.org/de/discuss/msg13382.html
[2] http://lists.freedesktop.org/archives/libreoffice-qa/2012-August/002360.html

Consens concerning the following question: "If a database-file (odb-file) is opened must this database be registered in LibreOffice?"
No.

IMHO an non-registered database must not result in an error (non-usability) or even crash/destroy data (= bug). Either this odb-file will be processed (user friendliest solution) or it is a message that this odb-file must be registered first (= feature).

Alex Thurgood comments:
I encountered the problem to which you are referring on Linux 64bit with
Robert's file. However, I had no such problem on Mac OSX. This was why I
registered the ODB file with LO on Linux before attempting to open it
again. This may have been particular to my setup, or the file in question.

Note that on Mac OSX Snow Leopard 10.6.8, Apple's file manager defaults
freshly downloaded files passed directly to an app as read-only, under
some kind of lame security policy, which forces the user to re-set the
write bit by hand or else move the file elsewhere (which seems to
automatically reset the read/write bits). However, this doesn't seem to
happen on OSX 10.8, and I can't compare with 10.7 because I didn't keep
it on my machine for very long
Comment 1 Jochen 2012-08-23 22:03:35 UTC
Created attachment 66035 [details]
odb-file don´t work
Comment 2 Rainer Bielefeld Retired 2012-08-24 04:57:20 UTC
NOT reproducible with "LibreOffice 3.6.1.2  German UI/Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit). I opened existing table with double clicks, relevant context menu items I tested all worked without problems. I can reproduce a message similar to Bug 53527#c8 with a vwite protected sample document, but write protection can not be healed by db registration?!

@reporter:
This is not a valid Bug report, important information is missing. Simply that you use the word "open" without telling us for what (See report results or edit report?) and how and not telling result about other possible actions (delete table ...) makes the report incomplete. There have been many useful hints in discussions and in Bug 53527 with plausible hypotheses concerning possible reasons for the observed problem, of course here references are required.

Please:
- Write a meaningful Summary describing exactly what the problem is
  (My version only is a little more precise than the former one, but not really
  exact (because the problem still is unknown, see below)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- Whether you have any idea what in this document might be different from
     other documents what work without problems for you.
  -- what EXACTLY is unexpected! "Can't be opened" is too tare. How are you
     trying? Double Click? Right click? Something else? What's happening? 
     Error Message? Nothing? Key board explodes? ;-)
  -- Whether it's possible to create a sample document from the scratch or 
     using an other document attached here in Bugzilla
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document File Menu?
     Explorer? Something else
  –- Whether your problem persists when you renamed your user profile
     before you launch LibO (please see
     <https://wiki.documentfoundation.org/UserProfile#User_profile_location>)
  –- Whether the document worked with other LibO Versions
  -- Whether the problem has been observed with other documents
  -- Whether the problem is reproducible with document in any folder on
    PC
  -- The sample document here looks at least very similar to the one in
     "Bug 53527 - EDITING ReportBuilder Field names not shown", IMHO it's the 
      same one
  -- everything else crossing your mind after you read linked texts
Comment 3 Rainer Bielefeld Retired 2012-08-24 05:23:23 UTC
During my research for this report I found some strange document write access effects what might be related "somehow", I still need some more experiments.
Comment 4 Jochen 2012-08-24 18:44:58 UTC
(In reply to comment #2)
> <snipp> I can reproduce a message similar to Bug 53527#c8 with a vwite
> protected sample document, but write protection can not be healed by db
> registration?!

Yes. I note my observation in bug 53527 (#c8). Now I create a extra bugreport.


> @reporter:
> This is not a valid Bug report, important information is missing.
sorry - I want to make it better.

> Simply that you use the word "open" without telling us for what (See report results or edit report?)
"Open" -> steps to reproduce:
1) After opening the odb-file on the left side there is the column "Database"
2) in "Tables" there exists one table - "Article"
3) Double click on "Article" don´t open the table "Artilce"
4) Following two error-messages occur:
Error 1 (see attach 2):
Die Verbindung zur Datenquelle "ReportBuilder_Textfields_without_Contentmarker"
konnte nicht hergestellt werden.
(The connection to datasource "ReportBuilder_Textfields_without_Contentmarker"
could not be made).
Error 2:
SQL-Status: S1000
Fehler-Code: -40
General error: org.hsqldb.lib.FileSystemRuntimeException: java.io.IOException:
c:/onegit/package/source/xstor/xstorage.cxx:3180:
5) Same behavior in the "reports" respectively double click on the report "Report"

Please note ### Important information ###:
After registration odb-file can be opened (logically). But:
After de-registration, i.e. removing the odb-file in Tools -> Options ->
LibreOffice Base -> Database -> Registered databases, and open the odb-file
again the odb-file works fine, i.e. the table "Article" and/or the report
"Report" can be opened.
Currently respectively after testing on various platforms I can´t reproduce my own bugreport but already in "virgin" systems (Windows XP and Windows 7 and LO  3.5.5 and LO 3.6.1).

IMHO there exits a problem/bug. But this is difficult to reproduce.
Comment 5 Jochen 2012-08-24 18:45:29 UTC
Created attachment 66080 [details]
error message
Comment 6 Rainer Bielefeld Retired 2012-08-26 05:54:43 UTC
I wonder whether "54067 - UI: Silent FILESAVE although user wants to discard" with some other unclear file access might be involved (or have the same roots). There I also saw a (probably) file access problem what  sometimes is reproducible and sometimes it is not.

I can reproduce the error messages when I make the document write protected in WIN explorer (in a public access folder), but that problem can't be healed for me by database registration. Registration seems to work, but access still remains impossible. And some effects differ to reporter's description, for example after opening the write protected document I already see an error message when I click "Tables" in Database Pane, while reporter will reach the Tables Pane and will see an error message later when he tries access to table itself.

Currently I find no way to reproduce reporter's problem, but info still is too rare.

Something strange I observe is that my WIN File Explorer very often crashes when I try to open the document (or a copy) from file explorer, and only these documents are affected, no other spreadsheets or similar 

@Jochen:
Please contribute more detailed and more precise description how you reproduce the bug. Path on HD, Antivirus software, WIN Settings, way how you open the document, installed Extensions, all that might be important in the current situation poking in the dark.

You should leave decision whether NEEDINFO still is required to the user who selected status to NEEDINFO. If you want to leave NEEDINFO the appropriate status to be selected is UNCONFIRMED until all info for bugfixing has been gained: <https://wiki.documentfoundation.org/BugTriage#Process>  item 5
Comment 7 Jochen 2012-08-26 09:21:31 UTC
(In reply to comment #6)
> @Jochen:
> Please contribute more detailed and more precise description how you reproduce
> the bug. Path on HD, Antivirus software, WIN Settings, way how you open the
> document, installed Extensions, all that might be important in the current
> situation poking in the dark.

> precise description how you reproduce the bug.
Currently respectively after testing on various platforms I can´t reproduce my
own bugreport. "After testing" means: registration odb-file to open the odb-file. Now testing the odb-file und reproducing the bug 53527. Then "de-registration" of the odb-file, i.e. removing the odb-file in Tools -> Options ->
LibreOffice Base -> Database -> Registered databases. 
I have only seen the "bug" in "virgin" systems (Windows XP and Windows 7 and LO 
3.5.5 and LO 3.6.1).

> Path on HD
Yes - C:\Users\<username>\Desktop

> Antivirus software
Yes - Avira Antivirus Premium (complete active)

> WIN Settings
What do you want to know?

> way how you open the document
Two ways:
1) Double-click on the odb-file using Windows-Explorer (C:\Users\<username>\Desktop\ReportBuilder_Textfields_without_Contentmarker.odb)
2) Start LibreOffice, i.e. double-click on "Start" (Windows) -> choose "LibreOffice" (e.g. "C:\Program Files (x86)\LibreOffice 3.5\program\soffice.exe") -> choosing "File" -> chossing "Open..." -> open C:\Users\<username>\Desktop\ReportBuilder_Textfields_without_Contentmarker.odb

> installed Extensions
No extenions in LO 3.6.1.1 RC
In LO 3.5.5 some extensions (productive system) like e.g. Batch2PDF or "Berichtassistent" or MySQL Connector.
MHO the extensions have no significance in this case -> reason: in LO 3.6.1.1 RC no extension are installed.

I suggest that status is set to "RESOLVED -> WORKSFORME".
Comment 8 Rainer Bielefeld Retired 2012-08-26 09:32:10 UTC
(In reply to comment #7)
> > Antivirus software
> Yes - Avira Antivirus Premium (complete active)

The same I use, so not really a candidate
 
> > WIN Settings
> What do you want to know?
If I would know ...

> 1) Double-click on the odb-file using Windows-Explorer
> (C:\Users\<username>\Desktop\ReportBuilder_Textfields_without_Contentmarker.odb)
> 2) Start LibreOffice, i.e. double-click on "Start" (Windows) -> choose
> "LibreOffice" (e.g. "C:\Program Files (x86)\LibreOffice
> 3.5\program\soffice.exe") -> choosing "File" -> chossing "Open..." -> open
> C:\Users\<username>\Desktop\ReportBuilder_Textfields_without_Contentmarker.odb

Both worked for me

> I suggest that status is set to "RESOLVED -> WORKSFORME".
I think currently we can't do anything else to find the roots, but my suspec is that this problem will reappear ...

@all:
Please feel free to reopen this bug if the problem reappears.