Bug Hunting Session
Bug 54054 - FILTER: File will not sort using autofilter
Summary: FILTER: File will not sort using autofilter
Status: RESOLVED DUPLICATE of bug 54018
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 13:05 UTC by john.pratt
Modified: 2012-08-25 15:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Demonstration of bug (14.44 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-08-25 13:05 UTC, john.pratt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john.pratt 2012-08-25 13:05:44 UTC
Created attachment 66105 [details]
Demonstration of bug

Problem description:
when sort (either ascending or descending) is selected it doesn't work.

Steps to reproduce:
1. open attached file
2. select sort from the autofilter dropdown (or sort from the Data menu)

Current behavior:
two boxes of progress bar appear and then nothing happens - libreoffice freezes

Expected behavior:
data gets sorted

Work around:
delete most of the data (although there is not a vast amount to start with)

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Rainer Bielefeld Retired 2012-08-25 15:51:17 UTC
[Reproducible] with "LibreOffice 3.6.1.2  German UI/Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) 

Reason for the problem is the comment in  C5. When the comment has been deleted sort will work without problems

Problem seems not related to using Sort in filter dialog, I also see the Crash when I use normal 'Data -> Sort'

So this one is a DUP of "Bug 54018 - EDITING: CRASH sorting cells range with Comments"
Comment 2 Rainer Bielefeld Retired 2012-08-25 15:51:37 UTC

*** This bug has been marked as a duplicate of bug 54018 ***