Bug 54018 - EDITING: CRASH sorting cells range with Comments
Summary: EDITING: CRASH sorting cells range with Comments
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.2 target:6.2.0
Keywords: regression
: 54054 54413 55247 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-08-24 16:59 UTC by Jochen
Modified: 2018-05-27 06:54 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
hausrat_test_LO.ods (24.18 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-08-24 17:00 UTC, Jochen
Details
Simple Sample (9.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-08-25 05:47 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2012-08-24 16:59:09 UTC
Steps to reproduce:
1) Open ods-file in attach 1 (hausrat_test_LO.ods)
2) Use sheet "Hausrat"
3) Try to sort by colum D, i.e. set cursor to D1 -> menue "Data" -> "Sort.."

OS: Windows XP

I´m not sure, if a problem with the ods-file exits or if one or more bugs exit.

Please note:
I create this bugreport, but I have not discovered this phenomen. I´m member of the German community and handled a request on German de-user-ML [1]

[1] http://listarchives.libreoffice.org/de/users/msg06647.html
Comment 1 Jochen 2012-08-24 17:00:07 UTC
Created attachment 66075 [details]
hausrat_test_LO.ods
Comment 2 Rainer Bielefeld Retired 2012-08-25 05:47:01 UTC
Created attachment 66090 [details]
Simple Sample

[Reproducible] with "LibreOffice 3.6.1.2  German UI/Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) :

Steps to reproduce:
1. open Sample document from LibO Start Center File Menu
2. click top left columns / rows heading field to select all cells
3. Menu 'Data -> Sort -> Column D -> Descending' <ok>
   Bug: When progress bar reaches 40% LibO Stops responding

Crash can not be healed by:
- Remove all other Sheets
- Clear direct formatting (for all cells in sheet)

Further research showed that the comments were the problem, deleting the comments from the sheet heals the problem.

So I was able to create a much more simple sample document, The problem is the comment in B2, it causes a crash when you sort ascending by column C
The problem vanishes  if you delete the comment before you sort.

No Crash with
- Server installation (own profile) of "LibreOffice  3.5.6.2  German UI/Locale 
  [Build-ID: e0fbe70-5879838-a0745b0-0cd1158-638b327] 
  on German WIN7 Home Premium (64bit) 
- And other 3.4, 3.4, 3.3 Versions
Comment 3 Rainer Bielefeld Retired 2012-08-25 05:56:38 UTC
Already [Reproducible] with Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit) 

No crash with
- Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)
Comment 4 Rainer Bielefeld Retired 2012-08-25 06:01:33 UTC
Comment on attachment 66075 [details]
hausrat_test_LO.ods

No longer required, more simple sample exists
Comment 5 Rainer Bielefeld Retired 2012-08-25 06:03:20 UTC
@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf. (and remove others in team from CC)
Comment 6 Rainer Bielefeld Retired 2012-08-25 07:07:21 UTC
Only crashes if comment is in range to be sorted.
Comment 7 Korrawit Pruegsanusak 2012-08-25 10:27:33 UTC
Bibisected and the result is in this range of 64 commits:

http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=5af303c0cd4d46c459c6b90712843967d716c866..efe7517856b5682b0f595822b953bf3ae4233588
Comment 8 Rainer Bielefeld Retired 2012-08-25 15:51:37 UTC
*** Bug 54054 has been marked as a duplicate of this bug. ***
Comment 9 Markus Mohrhard 2012-08-26 18:28:16 UTC
Already fixed. There were 2 relate problems that should be fixed both now.
Comment 10 Jochen 2012-08-31 19:23:10 UTC
@Markus:
On German user-ML was reported today that bug isn´t fix in Version 3.6.1.2 (Build ID: e29a214). What is your opinion?
Comment 11 Markus Mohrhard 2012-08-31 19:29:02 UTC
(In reply to comment #10)
> @Markus:
> On German user-ML was reported today that bug isn´t fix in Version 3.6.1.2
> (Build ID: e29a214). What is your opinion?

Opening a new bug report with a test document and a detailed instruction how to reproduce it. The bug mentioned here is fixed but there ight be another case.
Comment 12 john.pratt 2012-09-01 08:53:07 UTC
I agree that it is not fixed in 3.6.1.2, but it is fixed in the nightlies, so I assume that is what Markus means.
Comment 13 Rainer Bielefeld Retired 2012-09-03 04:46:52 UTC
@Markus:
Please correct my target info if it's wrong
Comment 14 Rainer Bielefeld Retired 2012-09-03 04:50:37 UTC
*** Bug 54413 has been marked as a duplicate of this bug. ***
Comment 15 Korrawit Pruegsanusak 2012-09-08 06:26:54 UTC
This bug is fixed along with bug 53979, see http://lists.freedesktop.org/archives/libreoffice/2012-August/037531.html

This fix is committed on August 27, but source for 3.6.1.2 was tagged on August 21 (see http://lists.freedesktop.org/archives/libreoffice/2012-August/037233.html). So this bug is fixed in 3.6.2 RC1 and later => set target accordingly.
Comment 16 GerardF 2012-09-23 19:12:21 UTC
*** Bug 55247 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2018-05-27 06:54:19 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=91cd384e8fb77db88bf75a9fc3b3213724cfc36d

uitest for bug tdf#54018

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.