Bug Hunting Session
Bug 54413 - Calc crashes on sorting cell range when a row contains a comment
Summary: Calc crashes on sorting cell range when a row contains a comment
Status: RESOLVED DUPLICATE of bug 54018
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 02:54 UTC by Charles
Modified: 2012-09-03 04:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2012-09-03 02:54:04 UTC
If one of the cells I am sorting contains a comment, the sort (on multiple columns) crashes Calc. The status bar progress (green bar) extends about 60% before it stops. Clac eventually shuts down after about 10 secs. The weird thing is that this was not happening before with ver 3.6.1.1... it just happened this week even though I have had this ver running and being sorted for a few weeks.
Comment 1 Rainer Bielefeld Retired 2012-09-03 04:50:37 UTC
I am pretty sure that reporter's problem is a DUP of "Bug 54018 - EDITING: CRASH sorting cells range with Comments".

That Bug and reporter's problem no longer  reproducible with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 9bb30a4]"  {tinderbox: 2008R2@20, pull time 2012-08-30 23:44:35} on German WIN7 Home Premium (64bit)

In Bug 54018 there is a small suspect that there might be an additional aspect of these crashes what is still unfixed, but currently no sample document what verifies that suspect is available.

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 54018 ***